aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Leise <marco.leise@gmx.de>2018-12-31 07:06:21 +0100
committerMarco Leise <marco.leise@gmx.de>2018-12-31 07:06:21 +0100
commitdd5d9fa0b8b1bcfaa765b48c957bb18ed6243cd4 (patch)
tree42cfdee82bdfb2d846f957b194233eaf0eaf2103 /dev-util/dfmt
parentnew .travis.yml (diff)
downloaddlang-dd5d9fa0b8b1bcfaa765b48c957bb18ed6243cd4.tar.gz
dlang-dd5d9fa0b8b1bcfaa765b48c957bb18ed6243cd4.tar.bz2
dlang-dd5d9fa0b8b1bcfaa765b48c957bb18ed6243cd4.zip
dfmt-0.9.0, dscanner-0.6.0 & onedrive-2.2.4
Diffstat (limited to 'dev-util/dfmt')
-rw-r--r--dev-util/dfmt/Manifest2
-rw-r--r--dev-util/dfmt/dfmt-0.9.0.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-util/dfmt/Manifest b/dev-util/dfmt/Manifest
index fc097be..afdea1c 100644
--- a/dev-util/dfmt/Manifest
+++ b/dev-util/dfmt/Manifest
@@ -1,3 +1,5 @@
DIST dfmt-0.8.3.tar.gz 80934 BLAKE2B 1592ff906e50a61d57d5a8c4460884ef575ffea292eb5528045de7980995e86176bcce229c2121b9150f5c4ea297d0f1e49c7d32c25936c6cb274b1f2bfd9a72 SHA512 aac50e05201367d7fe043d823b8ffb808b0955ac726fd5323837a40c71ba5bbd7006144cbb6e42c2f57028d8a4b3964bd7522455b839f01049d80f8e568727fa
+DIST dfmt-0.9.0.tar.gz 81100 BLAKE2B 1c19ad11d8b02091114b5c1650db5befa0318db09caea6c53f358598c0d0d61ebb3b300f3905ab8c48e78872b5b2d779b01d233e6ec4d29dc7fcfe10fb8e9ac6 SHA512 68d0b3eeecc0c2971c4b3da4b76b9e5466650fc84749b6f247a3c7b66cce25416f49722942e209b92a441e570d5f340bad584ca6ddcf4372a971d544d7df8467
DIST libdparse-086cf06051bb1f33c94891ba6c39a57f164ee296.tar.gz 115377 BLAKE2B ac33fa90edbdfa5a663933f8dcf384aaab95568565ce10fd476b0645bb8603bde68642a5aad619e330af1de4657a804efc4f958b3b85f0d227d068e5f55ce339 SHA512 1fc19e7e41a1a9275e4b25f1e9f48a16437843ed442dab759545f2b5f44d3bd128be9c8ece227086c3a95e2197d2794d2972db003ba412cb973a4d53adeb52ca
+DIST libdparse-ea63487efde96b6f169065d801bbcb8d7ed5dbb4.tar.gz 120550 BLAKE2B d7114362fdb5ba582ff8a6de35f689c00ed436ba9575e1cf373a7d8688e8487f9c4759f77102760beb859856e1cc02a90babc2c94a19a7fd5b5592e851feca6c SHA512 860b6c38d7fc7a2b5da981390e1c4b10cedb2da7419df6bbb3fc1fa46ac647235ee07baa532ca7bdf8095b0d7a2cdabcf20bc8efb73f5fc8491af6b57b3ed216
DIST stdx-allocator-b7778fd6bf5f9aaaa87dd27f989cefbf9b3b365f.tar.gz 103550 BLAKE2B be33b0df3a9be5a718c0f2286805946f2c20841bdf7032a4f454b7be76958a5789afaca94f430023918c25764f67fa5966f34fef1d7ca023e04a27735d5eda1b SHA512 d9a7688a45649a39d6a464a2f6a3acb0ee29b3aa17065afccc79d905701fc38fe48dd329687c065a016fc5f5291bb18e3e5b2877a286fd3e509766c7d9962e25
diff --git a/dev-util/dfmt/dfmt-0.9.0.ebuild b/dev-util/dfmt/dfmt-0.9.0.ebuild
new file mode 100644
index 0000000..4cc0c43
--- /dev/null
+++ b/dev-util/dfmt/dfmt-0.9.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Dfmt is a formatter for D source code"
+HOMEPAGE="https://github.com/dlang-community/dfmt"
+LICENSE="Boost-1.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LIBDPARSE="ea63487efde96b6f169065d801bbcb8d7ed5dbb4"
+ALLOCATOR="b7778fd6bf5f9aaaa87dd27f989cefbf9b3b365f"
+SRC_URI="
+ https://github.com/dlang-community/dfmt/archive/v${PV}.tar.gz -> ${PN}-${PV}.tar.gz
+ https://github.com/dlang-community/libdparse/archive/${LIBDPARSE}.tar.gz -> libdparse-${LIBDPARSE}.tar.gz
+ https://github.com/dlang-community/stdx-allocator/archive/${ALLOCATOR}.tar.gz -> stdx-allocator-${ALLOCATOR}.tar.gz
+ "
+
+DLANG_VERSION_RANGE="2.075-"
+DLANG_PACKAGE_TYPE="single"
+
+inherit dlang bash-completion-r1
+
+src_prepare() {
+ mkdir bin || die "Failed to create 'bin' directory."
+ cat > bin/githash.txt << EOF
+v${PV}
+EOF
+ dlang_src_prepare
+}
+
+d_src_compile() {
+ local libdparse_src="../libdparse-${LIBDPARSE}/src"
+ local allocator_src="../stdx-allocator-${ALLOCATOR}/source"
+ local imports="src ${libdparse_src} ${allocator_src}"
+ local string_imports="bin"
+
+ dlang_compile_bin "bin/dfmt" "src/dfmt/main.d" "src/dfmt/config.d" "src/dfmt/editorconfig.d" \
+ "src/dfmt/ast_info.d" "src/dfmt/indentation.d" "src/dfmt/tokens.d" "src/dfmt/wrapping.d" \
+ "src/dfmt/formatter.d" "src/dfmt/globmatch_editorconfig.d" \
+ ${libdparse_src}/dparse/lexer.d ${libdparse_src}/dparse/parser.d ${libdparse_src}/dparse/ast.d \
+ ${libdparse_src}/dparse/rollback_allocator.d ${libdparse_src}/dparse/stack_buffer.d \
+ ${libdparse_src}/std/experimental/lexer.d \
+ ${allocator_src}/stdx/allocator/common.d ${allocator_src}/stdx/allocator/mallocator.d \
+ ${allocator_src}/stdx/allocator/package.d ${allocator_src}/stdx/allocator/gc_allocator.d
+}
+
+d_src_test() {
+ cd tests && ./test.sh
+}
+
+d_src_install() {
+ dobin bin/dfmt
+ dodoc README.md LICENSE.txt
+ dobashcomp bash-completion/completions/dfmt
+}