aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/gdmd/gdmd-9.3.0.ebuild27
-rw-r--r--eclass/dlang-compilers.eclass1
-rw-r--r--profiles/use.desc1
3 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/gdmd/gdmd-9.3.0.ebuild b/dev-util/gdmd/gdmd-9.3.0.ebuild
new file mode 100644
index 0000000..e86456b
--- /dev/null
+++ b/dev-util/gdmd/gdmd-9.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Wrapper script for gdc that emulates the dmd command"
+HOMEPAGE="http://www.gdcproject.org/"
+LICENSE="GPL-3+"
+
+SLOT="${PV}"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+RDEPEND="=sys-devel/gcc-${PV}*[d]"
+RELEASE="0.1.0"
+SRC_URI="https://codeload.github.com/D-Programming-GDC/gdmd/tar.gz/script-${RELEASE} -> gdmd-${RELEASE}.tar.gz"
+PATCHES="${FILESDIR}/${PN}-no-dmd-conf.patch"
+S="${WORKDIR}/gdmd-script-${RELEASE}"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local binPath="usr/${CHOST}/gcc-bin/${PV}"
+ exeinto "${binPath}"
+ newexe dmd-script "${CHOST}-gdmd"
+ ln -f "${D}/${binPath}/${CHOST}-gdmd" "${D}/${binPath}/gdmd" || die "Could not create 'gdmd' hardlink"
+}
diff --git a/eclass/dlang-compilers.eclass b/eclass/dlang-compilers.eclass
index 5c24a64..b7d769d 100644
--- a/eclass/dlang-compilers.eclass
+++ b/eclass/dlang-compilers.eclass
@@ -47,6 +47,7 @@ dlang-compilers_declare_versions() {
# GDC (alpha, hppa, sparc: masked "d" USE-flag)
__dlang_gdc_frontend=(
["9.2.0"]="2.076 amd64 arm arm64 hppa ~ia64 m68k ~mips ppc ppc64 ~riscv s390 sparc x86"
+ ["9.3.0"]="2.076 amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
)
# LDC
diff --git a/profiles/use.desc b/profiles/use.desc
index 4ed36fe..490357b 100644
--- a/profiles/use.desc
+++ b/profiles/use.desc
@@ -27,6 +27,7 @@ dmd-2_088 - Build for DMD 2.088
dmd-2_089 - Build for DMD 2.089
dmd-2_090 - Build for DMD 2.090
gdc-9_2_0 - Build for GCC 9.2.0
+gdc-9_3_0 - Build for GCC 9.3.0
ldc2-1_12 - Build for ldc2 1.12
ldc2-1_13 - Build for ldc2 1.13
ldc2-1_14 - Build for ldc2 1.14