aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerion Entrup <gerion.entrup@flump.de>2018-09-18 15:59:34 +0200
committerGerion Entrup <gerion.entrup@flump.de>2018-09-18 15:59:34 +0200
commit7132aa7c7d7512d9800b5ef722c65b376cc74f8c (patch)
tree6623fb126b905d45285dc6eaaf076fcd2862b97c
parentmedia-gfx/leocad: add 18.02 version (diff)
downloadgerislay-7132aa7c7d7512d9800b5ef722c65b376cc74f8c.tar.gz
gerislay-7132aa7c7d7512d9800b5ef722c65b376cc74f8c.tar.bz2
gerislay-7132aa7c7d7512d9800b5ef722c65b376cc74f8c.zip
app-misc/vimpager: add
-rw-r--r--app-misc/vimpager/Manifest1
-rw-r--r--app-misc/vimpager/vimpager-9999.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/app-misc/vimpager/Manifest b/app-misc/vimpager/Manifest
new file mode 100644
index 0000000..4408b6d
--- /dev/null
+++ b/app-misc/vimpager/Manifest
@@ -0,0 +1 @@
+EBUILD vimpager-9999.ebuild 585 BLAKE2B 13ba4ff8581932ca8c0ccb6febed7b0e88f4612b9b3970e4e58872781b351e1fc374e173812d0b8f4083f2c7af122016368faa00052b81157bebe8b9777e38c3 SHA512 e58f1fe455de76d2515e26f7ce064b9976ac62aca4dee6da15648c4eebffe0bbd6beedba6ecd2197bc922d515176efbca1e3307abdb369b3ac8918331b6b4d8b
diff --git a/app-misc/vimpager/vimpager-9999.ebuild b/app-misc/vimpager/vimpager-9999.ebuild
new file mode 100644
index 0000000..f232f8e
--- /dev/null
+++ b/app-misc/vimpager/vimpager-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3
+
+DESCRIPTION="Use Vim as PAGER"
+HOMEPAGE=i"https://www.vim.org/scripts/script.php?script_id=1723"
+EGIT_REPO_URI="https://github.com/rkitover/${PN}.git"
+
+LICENSE="MIT VIM4 BSD2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+pandoc doctoc"
+
+DEPEND="|| ( app-editors/vim app-editors/neovim )
+ app-arch/sharutils
+ pandoc? ( app-text/pandoc )
+ doctoc? ( app-doc/doctoc )"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+}