aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerion Entrup <gerion.entrup@flump.de>2017-09-26 02:07:35 +0200
committerGerion Entrup <gerion.entrup@flump.de>2017-09-26 02:07:35 +0200
commit4fe4a46f85522045e69c2004dcd4975e3ebce0b9 (patch)
tree8450f4adee707d88e857e9b4178012359cc8dcb6 /media-plugins
parentdev-python/python-crontab: new ebuild 2.2.2 (diff)
downloadgerislay-4fe4a46f85522045e69c2004dcd4975e3ebce0b9.tar.gz
gerislay-4fe4a46f85522045e69c2004dcd4975e3ebce0b9.tar.bz2
gerislay-4fe4a46f85522045e69c2004dcd4975e3ebce0b9.zip
hyperion: add git version
not tested very well
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/hyperion/Manifest1
-rw-r--r--media-plugins/hyperion/hyperion-9999.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/media-plugins/hyperion/Manifest b/media-plugins/hyperion/Manifest
new file mode 100644
index 0000000..e02b7d2
--- /dev/null
+++ b/media-plugins/hyperion/Manifest
@@ -0,0 +1 @@
+EBUILD hyperion-9999.ebuild 1028 SHA256 6558ee8c4d22cea031d338d2cd0cbd23357ff12810e59910ab5b08d493647109 SHA512 9432f7d5bea615fe4a4520e735c64f6311350fda8dd1e2dc23bab39b9af3063c46a4e391eaf3c8cf136fb1d2cd2647bbf9570d2ee93d39bd94f01d7a181e71d2 WHIRLPOOL 150d601a78d2362b2f848dc98eea763206d17e8234621eed25361fadac02f2814c702aa60a99cafb6664f5de8ce48cef11b1c3e91892cdd5b27b06d71af33f6d
diff --git a/media-plugins/hyperion/hyperion-9999.ebuild b/media-plugins/hyperion/hyperion-9999.ebuild
new file mode 100644
index 0000000..b083454
--- /dev/null
+++ b/media-plugins/hyperion/hyperion-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit git-r3 cmake-utils
+
+DESCRIPTION="An opensource 'AmbiLight' implementation supported by many devices"
+HOMEPAGE="https://hyperion-project.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/hyperion-project/${PN}"
+EGIT_SUBMODULES=()
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="dispmanx framebuffer spi +qt5 vfl"
+
+DEPEND="x11-libs/libXrender
+ dev-util/cmake
+ virtual/libusb
+ dev-libs/icu
+ qt5? ( dev-qt/qtcore:5
+ dev-qt/qtserialport:5 )
+ dev-lang/python
+ net-dns/avahi
+ dev-libs/protobuf"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DISPMANX="$(usex dispmanx)"
+ -DENABLE_FB="$(usex framebuffer)"
+ -DENABLE_SPIDEV="$(usex spi)"
+ -DENABLE_QT5="$(usex qt5)"
+ -DENABLE_VFL2="$(usex vfl)"
+ -DCMAKE_BUILD_TYPE=Release
+ -DUSE_SYSTEM_PROTO_LIBS=on
+ -DUSE_SHARED_AVAHI_LIBS=on
+ -DPROTOBUF_PROTOC_EXECUTABLE=/usr/bin/protoc
+ -DPLATFORM=x86
+ -Wno-dev
+ )
+ cmake-utils_src_configure
+}