aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/py-spy/py-spy-0.3.12.ebuild')
-rw-r--r--dev-python/py-spy/py-spy-0.3.12.ebuild190
1 files changed, 190 insertions, 0 deletions
diff --git a/dev-python/py-spy/py-spy-0.3.12.ebuild b/dev-python/py-spy/py-spy-0.3.12.ebuild
new file mode 100644
index 0000000..f2da463
--- /dev/null
+++ b/dev-python/py-spy/py-spy-0.3.12.ebuild
@@ -0,0 +1,190 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES="
+ addr2line-0.17.0
+ adler-1.0.2
+ ahash-0.7.6
+ aho-corasick-0.7.18
+ android_system_properties-0.1.4
+ ansi_term-0.12.1
+ anyhow-1.0.52
+ arrayvec-0.4.12
+ atty-0.2.14
+ autocfg-1.0.1
+ backtrace-0.3.63
+ bindgen-0.59.2
+ bitflags-1.3.2
+ bumpalo-3.11.0
+ bytemuck-1.7.3
+ cc-1.0.72
+ cexpr-0.6.0
+ cfg-if-1.0.0
+ chrono-0.4.22
+ clang-sys-1.3.0
+ clap-2.34.0
+ clap-3.1.15
+ clap_complete-3.1.3
+ clap_derive-3.1.7
+ clap_lex-0.2.0
+ console-0.15.0
+ core-foundation-sys-0.8.3
+ cpp_demangle-0.3.5
+ crc32fast-1.3.0
+ crossbeam-channel-0.5.1
+ crossbeam-utils-0.8.5
+ ctrlc-3.2.1
+ dashmap-5.2.0
+ either-1.6.1
+ encode_unicode-0.3.6
+ env_logger-0.9.0
+ errno-0.2.8
+ errno-dragonfly-0.1.2
+ failure-0.1.8
+ failure_derive-0.1.8
+ fallible-iterator-0.2.0
+ flate2-1.0.22
+ getrandom-0.2.3
+ gimli-0.26.1
+ glob-0.3.0
+ goblin-0.4.3
+ goblin-0.5.1
+ hashbrown-0.11.2
+ heck-0.4.0
+ hermit-abi-0.1.19
+ humantime-2.1.0
+ iana-time-zone-0.1.46
+ indexmap-1.7.0
+ indicatif-0.16.2
+ inferno-0.11.2
+ itoa-0.4.8
+ itoa-1.0.1
+ js-sys-0.3.59
+ lazy_static-1.4.0
+ lazycell-1.3.0
+ libc-0.2.132
+ libloading-0.7.2
+ libm-0.2.1
+ libproc-0.10.0
+ libproc-0.12.0
+ lock_api-0.4.6
+ log-0.4.14
+ lru-0.7.2
+ mach-0.3.2
+ mach2-0.4.0
+ mach_o_sys-0.1.1
+ memchr-2.4.1
+ memmap-0.7.0
+ memoffset-0.6.5
+ minimal-lexical-0.2.1
+ miniz_oxide-0.4.4
+ nix-0.23.1
+ nix-0.24.1
+ nodrop-0.1.14
+ nom-7.1.0
+ num-format-0.4.0
+ num-integer-0.1.44
+ num-traits-0.2.14
+ num_cpus-1.13.1
+ number_prefix-0.4.0
+ object-0.27.1
+ once_cell-1.13.1
+ os_str_bytes-6.0.0
+ parking_lot-0.12.0
+ parking_lot_core-0.9.3
+ peeking_take_while-0.1.2
+ plain-0.2.3
+ ppv-lite86-0.2.16
+ proc-macro-error-1.0.4
+ proc-macro-error-attr-1.0.4
+ proc-macro2-1.0.36
+ proc-maps-0.2.1
+ quick-xml-0.22.0
+ quote-1.0.14
+ rand-0.8.4
+ rand_chacha-0.3.1
+ rand_core-0.6.3
+ rand_distr-0.4.2
+ rand_hc-0.3.1
+ read-process-memory-0.1.4
+ redox_syscall-0.2.10
+ regex-1.6.0
+ regex-syntax-0.6.27
+ remoteprocess-0.4.9
+ remove_dir_all-0.5.3
+ rgb-0.8.31
+ rustc-demangle-0.1.21
+ rustc-hash-1.1.0
+ ryu-1.0.9
+ scopeguard-1.1.0
+ scroll-0.10.2
+ scroll-0.11.0
+ scroll_derive-0.10.5
+ scroll_derive-0.11.0
+ serde-1.0.133
+ serde_derive-1.0.133
+ serde_json-1.0.74
+ shlex-1.1.0
+ smallvec-1.7.0
+ stable_deref_trait-1.2.0
+ str_stack-0.1.0
+ strsim-0.8.0
+ strsim-0.10.0
+ syn-1.0.84
+ synstructure-0.12.6
+ tempfile-3.2.0
+ termcolor-1.1.2
+ terminal_size-0.1.17
+ termios-0.3.3
+ textwrap-0.11.0
+ textwrap-0.15.0
+ time-0.1.44
+ unicode-width-0.1.9
+ unicode-xid-0.2.2
+ vec_map-0.8.2
+ version_check-0.9.4
+ wasi-0.10.0+wasi-snapshot-preview1
+ wasm-bindgen-0.2.82
+ wasm-bindgen-backend-0.2.82
+ wasm-bindgen-macro-0.2.82
+ wasm-bindgen-macro-support-0.2.82
+ wasm-bindgen-shared-0.2.82
+ which-4.2.2
+ winapi-0.3.9
+ winapi-i686-pc-windows-gnu-0.4.0
+ winapi-util-0.1.5
+ winapi-x86_64-pc-windows-gnu-0.4.0
+ windows-sys-0.36.1
+ windows_aarch64_msvc-0.36.1
+ windows_i686_gnu-0.36.1
+ windows_i686_msvc-0.36.1
+ windows_x86_64_gnu-0.36.1
+ windows_x86_64_msvc-0.36.1
+"
+DISTUTILS_USE_PEP517=maturin
+PYTHON_COMPAT=( python3_{8..11} )
+inherit cargo distutils-r1
+
+MY_PN="py_spy"
+
+DESCRIPTION="Sampling profiler for Python programs"
+HOMEPAGE="https://github.com/benfred/py-spy"
+SRC_URI="
+ https://github.com/benfred/py-spy/releases/download/v${PV}/${MY_PN}-${PV}.tar.gz
+ $(cargo_crate_uris)"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD BSD-2 Boost-1.0 CDDL ISC MIT Unlicense ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# TODO: the package support testing but I'm not sure how exactly
+
+PATCHES=( "${FILESDIR}/0.3.12-fix-possible-security-vulnerabilities.patch" )
+DOCS=( CHANGELOG.md README.md )
+
+src_compile() {
+ distutils-r1_src_compile
+}