aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuel Bernardo <samuelbernardo.mail@gmail.com>2017-07-23 12:56:19 +0100
committerSamuel Bernardo <samuelbernardo.mail@gmail.com>2017-07-23 12:56:19 +0100
commit583e2b2befab9c068bca979daa815439fdd4ccd9 (patch)
tree01be839f7a7f79a5abf1546c113cdf489a9ea983 /app-emulation
parentcorrect bug in clion ebuild for latest version (diff)
downloadssnb-583e2b2befab9c068bca979daa815439fdd4ccd9.tar.gz
ssnb-583e2b2befab9c068bca979daa815439fdd4ccd9.tar.bz2
ssnb-583e2b2befab9c068bca979daa815439fdd4ccd9.zip
add supermin
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/supermin/Manifest3
-rw-r--r--app-emulation/supermin/metadata.xml21
-rw-r--r--app-emulation/supermin/supermin-5.1.18.ebuild63
-rw-r--r--app-emulation/supermin/supermin-9999.ebuild63
4 files changed, 150 insertions, 0 deletions
diff --git a/app-emulation/supermin/Manifest b/app-emulation/supermin/Manifest
new file mode 100644
index 0000000..0deebdf
--- /dev/null
+++ b/app-emulation/supermin/Manifest
@@ -0,0 +1,3 @@
+EBUILD supermin-5.1.18.ebuild 1259 SHA256 df439c46910b2e067cfc893e8dda5c3137da9a11a24e351da7f18bbab4feaf47 SHA512 b500a71d213ae9fd7e2ae0d541284c99b09c9ea2ec4c13d1110042863180049aa3529f3d7cbf34ed9f2805f1ea37e600eddfec4c192bd18323a03cd621e3583e WHIRLPOOL 0b0d35d05fd078ba00040c6a4df72b8001614963e5b02c9b94365fb4bf892d18dd46a136c81786534b8a73ff24f27f83e897c4f8439b3fdd22477dcbdddc777f
+EBUILD supermin-9999.ebuild 1259 SHA256 df439c46910b2e067cfc893e8dda5c3137da9a11a24e351da7f18bbab4feaf47 SHA512 b500a71d213ae9fd7e2ae0d541284c99b09c9ea2ec4c13d1110042863180049aa3529f3d7cbf34ed9f2805f1ea37e600eddfec4c192bd18323a03cd621e3583e WHIRLPOOL 0b0d35d05fd078ba00040c6a4df72b8001614963e5b02c9b94365fb4bf892d18dd46a136c81786534b8a73ff24f27f83e897c4f8439b3fdd22477dcbdddc777f
+MISC metadata.xml 671 SHA256 729595d9a11903236c4aedfc9397663fdab2fb5a623f4178be73f24f24999c42 SHA512 9686312623976518279db082f686ccdf1155a76d18d873d23255c0f8ccbf4df4ffd4b36f250d73ccaea067802e985077638ff678494c73aa02a81a0020f2ee21 WHIRLPOOL 3a0933ca91a47614a47ed593818ebe8732bf6ffd62c437e6ca7ae4072aa411da9250c32593c0276fe1e0e7a41bb3d611e71900747e21ccc280b383a9be7ad864
diff --git a/app-emulation/supermin/metadata.xml b/app-emulation/supermin/metadata.xml
new file mode 100644
index 0000000..81fd502
--- /dev/null
+++ b/app-emulation/supermin/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>supermin</herd>
+ <longdescription>
+ Supermin is a tool for building supermin appliances.
+ These are tiny appliances [similar to virtual machines],
+ usually around 100KB in size, which get fully instantiated
+ on-the-fly in a fraction of a second when you need to boot
+ one of them.
+
+ Official documentation at
+ http://people.redhat.com/~rjones/supermin/
+ </longdescription>
+ <use>
+ <flag name='test'>Enable tests with network connection.
+ If you don't have a network connection let it
+ disabled.
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/app-emulation/supermin/supermin-5.1.18.ebuild b/app-emulation/supermin/supermin-5.1.18.ebuild
new file mode 100644
index 0000000..a886f0b
--- /dev/null
+++ b/app-emulation/supermin/supermin-5.1.18.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils git-r3 autotools user
+
+AM_OPTS="-i" #define eautoreconf options
+#AT_NOELIBTOOLIZE="yes" #disable elibtoolize because eautoreconf is crashing at this phase
+
+if [[ $PV = *9999* ]]; then
+ EGIT_REPO_URI="
+ https://github.com/libguestfs/supermin.git
+ git@github.com:libguestfs/supermin.git"
+ EGIT_SUBMODULES=( '*' )
+ SRC_URI=""
+ KEYWORDS=""
+else
+ EGIT_REPO_URI="
+ https://github.com/libguestfs/supermin.git
+ git@github.com:libguestfs/supermin.git"
+ EGIT_SUBMODULES=( '*' )
+ EGIT_COMMIT="v$PV"
+ SRC_URI=""
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Tool for creating supermin appliances"
+HOMEPAGE="http://libguestfs.org"
+
+LICENSE="GPL"
+SLOT="0"
+IUSE="test"
+
+DEPEND="
+ dev-lang/ocaml
+ dev-ml/findlib[-tk]
+ dev-lang/perl
+ app-shells/bash
+ sys-devel/gcc
+ sys-apps/gawk
+ >=sys-devel/prelink-20151030
+ app-arch/cpio
+ "
+RDEPEND="
+ sys-fs/e2fsprogs
+ !<=dev-util/febootstrap-3.21
+ "
+
+src_prepare() {
+ "${S}/.gnulib/gnulib-tool" --update >/dev/null 2>&1 || die "gnulib-tool --update failed!"
+ eautoreconf
+ eapply_user
+}
+
+src_configure() {
+ econf $(use_enable !test disable-network-tests)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}
+
diff --git a/app-emulation/supermin/supermin-9999.ebuild b/app-emulation/supermin/supermin-9999.ebuild
new file mode 100644
index 0000000..a886f0b
--- /dev/null
+++ b/app-emulation/supermin/supermin-9999.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils git-r3 autotools user
+
+AM_OPTS="-i" #define eautoreconf options
+#AT_NOELIBTOOLIZE="yes" #disable elibtoolize because eautoreconf is crashing at this phase
+
+if [[ $PV = *9999* ]]; then
+ EGIT_REPO_URI="
+ https://github.com/libguestfs/supermin.git
+ git@github.com:libguestfs/supermin.git"
+ EGIT_SUBMODULES=( '*' )
+ SRC_URI=""
+ KEYWORDS=""
+else
+ EGIT_REPO_URI="
+ https://github.com/libguestfs/supermin.git
+ git@github.com:libguestfs/supermin.git"
+ EGIT_SUBMODULES=( '*' )
+ EGIT_COMMIT="v$PV"
+ SRC_URI=""
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Tool for creating supermin appliances"
+HOMEPAGE="http://libguestfs.org"
+
+LICENSE="GPL"
+SLOT="0"
+IUSE="test"
+
+DEPEND="
+ dev-lang/ocaml
+ dev-ml/findlib[-tk]
+ dev-lang/perl
+ app-shells/bash
+ sys-devel/gcc
+ sys-apps/gawk
+ >=sys-devel/prelink-20151030
+ app-arch/cpio
+ "
+RDEPEND="
+ sys-fs/e2fsprogs
+ !<=dev-util/febootstrap-3.21
+ "
+
+src_prepare() {
+ "${S}/.gnulib/gnulib-tool" --update >/dev/null 2>&1 || die "gnulib-tool --update failed!"
+ eautoreconf
+ eapply_user
+}
+
+src_configure() {
+ econf $(use_enable !test disable-network-tests)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}
+