summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Miess <Philip_Miess@yahoo.com>2017-07-09 09:02:50 -0400
committerPhilip Miess <Philip_Miess@yahoo.com>2017-07-09 09:02:50 -0400
commitffcfb573654646d3fa93aa2f5d3ff01e2d3886a8 (patch)
tree23b79a2902a42cc0c2e05e9624dd88f17cbb46f2 /games-kids
parentno commas in make_desktop_entery (diff)
downloadsuperposition-ffcfb573654646d3fa93aa2f5d3ff01e2d3886a8.tar.gz
superposition-ffcfb573654646d3fa93aa2f5d3ff01e2d3886a8.tar.bz2
superposition-ffcfb573654646d3fa93aa2f5d3ff01e2d3886a8.zip
scratch & sqeak
Diffstat (limited to 'games-kids')
-rw-r--r--games-kids/scratch/Manifest3
-rw-r--r--games-kids/scratch/metadata.xml31
-rw-r--r--games-kids/scratch/scratch-1.4.0.7.ebuild101
3 files changed, 135 insertions, 0 deletions
diff --git a/games-kids/scratch/Manifest b/games-kids/scratch/Manifest
new file mode 100644
index 0000000..f318769
--- /dev/null
+++ b/games-kids/scratch/Manifest
@@ -0,0 +1,3 @@
+DIST scratch-1.4.0.7.src.tar.gz 47617852 SHA256 b94d89278ecef2ba2d1147eec23936dd99697293ffa2c216c0a375ba98226a3e SHA512 a5dba21855ad2d087e0d76066ee70c6f36c67c66deccb6eb001249bc25391b0f9036d9fd2ab8383ef54c414e743dff23e9e52ab1c73dd7200f36d7d47c62f562 WHIRLPOOL 4b199541a252b51cded9e41f7e511d2d0cbae77161c8d234b277ecc204fe6d36663367934e7200eb179229ca4b0f6b45d060a7fc51044f20f8aa0944a7ec2ac8
+EBUILD scratch-1.4.0.7.ebuild 2387 SHA256 e31d2d16e7d0f89237d6bf5ccf3b223fda77d7c7a3cf412662b720c30b357c43 SHA512 9a078596955297381ac12d803b6d1a94df68bf10a46caa90f65eabb6603f902a3287747aadd51beaf8f2b510abc43cdcca7330f13adef9df955e8ad4be155b7e WHIRLPOOL 5e6a6716e6eb2ba14000387d4fc12ea7c4f0a44206df8d5a265368418023f47a6588eaa2742b0efe44e3061d9b89ed54f6252e8cb03514cb7bf8364f169535a7
+MISC metadata.xml 965 SHA256 bb5ea13c29cce825fb15ec61b5452e3aaec9e34a2d25a5d7572f088d2a68df54 SHA512 5a39dd1ae9b5b7f592794afe7558b5567689b05cea4aadc67df8e87b473617dfa74402f9cd7b7fb8dddc876bcabfd377f373d99d20fd37b02d3a1221ab750138 WHIRLPOOL bae3374dd122e4b47f35b247b08294f945c9dbb9745b404247ad3e675fc51b91951a4821a76d96442dd6fd7d4ffb8144d30e1a069bbfb4439acae65cccd40a0c
diff --git a/games-kids/scratch/metadata.xml b/games-kids/scratch/metadata.xml
new file mode 100644
index 0000000..39f277e
--- /dev/null
+++ b/games-kids/scratch/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<longdescription lang="en">
+Scratch is a new programming language that makes it easy to create your
+own interactive stories, animations, games, music, and art -- and share
+your creations on the web.
+
+Scratch is designed to help young people (ages 8 and up) develop 21st
+century learning skills. As they create Scratch projects, young people
+learn important mathematical and computational ideas, while also gaining
+a deeper understanding of the process of design.
+</longdescription>
+<use>
+ <flag name="alsa">
+ Use the alsa driver plugin for sound
+ </flag>
+ <flag name="oss">
+ Use the oss driver plugin for sound
+ </flag>
+ <flag name="pulseaudio">
+ Use the pulse audio driver plugin for sound
+ </flag>
+ <flag name="nas">
+ Use the nas driver plugin for sound
+ </flag>
+ <flag name="v4l">
+ Use the camera plugin
+ </flag>
+</use>
+</pkgmetadata>
diff --git a/games-kids/scratch/scratch-1.4.0.7.ebuild b/games-kids/scratch/scratch-1.4.0.7.ebuild
new file mode 100644
index 0000000..ebaf92f
--- /dev/null
+++ b/games-kids/scratch/scratch-1.4.0.7.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit confutils gnome2-utils fdo-mime
+
+DESCRIPTION="A programming environment for creating and sharing interactive stories, animations, games, music, and art."
+HOMEPAGE="http://scratch.mit.edu/"
+SRC_URI="http://download.scratch.mit.edu/${P}.src.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa oss pulseaudio nas +v4l"
+
+DEPEND="dev-lang/squeakvm[scratch]
+ alsa? ( dev-lang/squeakvm[alsa] )
+ oss? ( dev-lang/squeakvm[oss] )
+ pulseaudio? ( dev-lang/squeakvm[pulseaudio] )
+ nas? ( dev-lang/squeakvm[nas] )
+ v4l? ( dev-lang/squeakvm[v4l] )"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="?? ( alsa oss pulseaudio nas )"
+
+S="${WORKDIR}/${P}.src"
+
+src_prepare() {
+ rm -rf src/plugins/*
+ rm -f Makefile
+ eapply_user
+}
+
+src_configure(){
+
+if use alsa; then squeak_sound_plugin="ALSA"
+elif use oss; then squeak_sound_plugin="OSS"
+elif use pulseaudio; then squeak_sound_plugin="pulse"
+elif use nas; then squeak_sound_plugin="nas"
+else squeak_sound_plugin="null"
+fi
+
+}
+
+
+src_install() {
+ local datadir="/usr/share/${PN}"
+ local icondir="/usr/share/icons/hicolor"
+ dodir "${datadir}"
+ cp -r Help locale Media Projects "${D}${datadir}"
+ doman src/man/*
+ dodoc ACKNOWLEDGEMENTS KNOWN-BUGS README NOTICE TRADEMARK_POLICY
+ insinto /usr/share/mime/packages
+ doins src/scratch.xml
+ dolib Scratch.image
+ dolib Scratch.ini
+ (
+ cd src/icons
+ for res in *; do
+ insinto "${icondir}/${res}/apps"
+ doins "${res}"/scratch*.png
+ insinto "${icondir}/${res}/mimetypes"
+ if [[ ${res} != "32x32" ]]; then
+ newins "${res}/gnome-mime-application-x-scratch-project.png" mime-application-x-scratch-project.png
+ fi
+ done
+ )
+ install_runner
+ make_desktop_entry scratch Scratch scratch "Education;Development" "MimeType=application/x-scratch-project"
+}
+
+install_runner() {
+ local tmpexe=$(emktemp)
+ cat << EOF > "${tmpexe}"
+#!/bin/sh
+cd
+exec \
+ "/usr/bin/squeak" \\
+ -vm-sound-${squeak_sound_plugin} \\
+ "/usr/$(get_libdir)/Scratch.image" \\
+ "${@}"
+EOF
+ chmod go+rx "${tmpexe}"
+ newbin "${tmpexe}" "${PN}" || die
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}