summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/lwjgl3/lwjgl3-3.1.3.ebuild')
-rw-r--r--dev-java/lwjgl3/lwjgl3-3.1.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-java/lwjgl3/lwjgl3-3.1.3.ebuild b/dev-java/lwjgl3/lwjgl3-3.1.3.ebuild
new file mode 100644
index 0000000..0ab3ba3
--- /dev/null
+++ b/dev-java/lwjgl3/lwjgl3-3.1.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source test"
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="LWJGL is a Java library that enables cross-platform access to popular native APIs useful in the development of graphics (OpenGL), audio (OpenAL) and parallel computing (OpenCL) applications."
+HOMEPAGE="https://www.lwjgl.org/"
+SRC_URI="https://github.com/LWJGL/lwjgl3/archive/3.1.3.tar.gz"
+
+LICENSE="BSD"
+SLOT="3.1"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.8"
+RDEPEND=">=virtual/jre-1.8"
+
+JAVA_PKG_STRICT=true
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_ANT_TASKS="compile-templates,generate,compile,compile-native"
+
+
+java_prepare() {
+ # This does not discriminate,
+ # it will remove ALL .class and .jar files
+ java-pkg_clean
+}
+
+