summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-sha/ocaml-sha-1.9.ebuild')
-rw-r--r--dev-ml/ocaml-sha/ocaml-sha-1.9.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/ocaml-sha/ocaml-sha-1.9.ebuild b/dev-ml/ocaml-sha/ocaml-sha-1.9.ebuild
new file mode 100644
index 0000000..79c63c3
--- /dev/null
+++ b/dev-ml/ocaml-sha/ocaml-sha-1.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib vcs-snapshot
+
+DESCRIPTION="A binding for SHA interface code in OCaml"
+HOMEPAGE="https://github.com/vincenthz/ocaml-sha"
+SRC_URI="https://github.com/vincenthz/ocaml-sha/archive/${PN}-v${PV}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt]"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README
+}