aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Brewer <tomboy64@sina.cn>2016-05-18 19:43:55 +0200
committerMatthew Brewer <tomboy64@sina.cn>2016-05-18 19:44:55 +0200
commit93e8b224454bfdb38b22a8572eadafce6410e358 (patch)
tree7b30664fb2ccef0f27e035676a44ec20183b4717 /dev-lang/nqp/nqp-2016.04.ebuild
parentchroot-here.sh v1.0 (diff)
downloadtbc-93e8b224454bfdb38b22a8572eadafce6410e358.tar.gz
tbc-93e8b224454bfdb38b22a8572eadafce6410e358.tar.bz2
tbc-93e8b224454bfdb38b22a8572eadafce6410e358.zip
dev-lang/nqp: 2016.04 (experimental\!)
Diffstat (limited to 'dev-lang/nqp/nqp-2016.04.ebuild')
-rw-r--r--dev-lang/nqp/nqp-2016.04.ebuild79
1 files changed, 28 insertions, 51 deletions
diff --git a/dev-lang/nqp/nqp-2016.04.ebuild b/dev-lang/nqp/nqp-2016.04.ebuild
index 4354072..4a45644 100644
--- a/dev-lang/nqp/nqp-2016.04.ebuild
+++ b/dev-lang/nqp/nqp-2016.04.ebuild
@@ -1,79 +1,56 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=6
+EAPI=5
-inherit java-pkg-2
+# still not working
+RESTRICT="test"
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/perl6/${PN}.git"
- inherit git-r3
- KEYWORDS=""
-else
- SRC_URI="https://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"
- KEYWORDS="~x86 ~amd64"
-fi
+inherit eutils multilib versionator
+
+GITCRAP=10d3ecc
DESCRIPTION="Not Quite Perl, a Perl 6 bootstrapping compiler"
HOMEPAGE="http://rakudo.org/"
+SRC_URI="https://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"
LICENSE="Artistic-2"
SLOT="0"
-IUSE="doc clang java +moar test"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc java +moar"
REQUIRED_USE="|| ( java moar )"
-RDEPEND="java? ( >=virtual/jre-1.7:*
- dev-java/asm:4
- dev-java/jline:0 )
- moar? ( ~dev-lang/moarvm-${PV}[clang=] )
+RDEPEND="
+ java? ( >=virtual/jre-1.7 )
+ moar? ( ~dev-lang/moarvm-${PV} )
dev-libs/libffi"
DEPEND="${RDEPEND}
- clang? ( sys-devel/clang )
- java? ( >=virtual/jdk-1.7:* )
+ java? ( >=virtual/jdk-1.7 )
dev-lang/perl"
-PATCHES=( "${FILESDIR}/enable-external-jars.patch" )
-
-pkg_setup() {
- use java && java-pkg-2_pkg_setup
-}
-
-src_prepare() {
- eapply "${PATCHES[@]}"
- eapply_user
- use java && java-pkg-2_src_prepare
-}
-src_unpack() {
- if [[ ${PV} == "9999" ]]; then
- git-r3_src_unpack
- else
- unpack ${A}
- mv "${WORKDIR}/perl6-nqp-"* "${WORKDIR}/${P}" || die
- fi
-}
+S=${WORKDIR}/perl6-nqp-${GITCRAP}
src_configure() {
- # 2016.04 doesn't like our jna-3.4.1
- # keep testing against it
- local backends
- use java && backends+="jvm,"
- use moar && backends+="moar"
- local myconfargs=(
- "--backend=${backends}"
- "--with-asm=$(echo $(java-pkg_getjars asm-4) | tr : '\n' | grep '/asm\.jar$')"
- "--with-asm-tree=$(echo $(java-pkg_getjars asm-4) | tr : '\n' | grep '/asm-tree\.jar$')"
- "--with-jline=$(echo $(java-pkg_getjars jline) | tr : '\n' | grep '/jline\.jar$')"
- "--prefix=/usr" )
- perl Configure.pl "${myconfargs[@]}" || die
+ use java && myconf+="jvm,"
+ use moar && myconf+="moar,"
+ perl Configure.pl --backend=${myconf} --prefix=/usr || die
+ # dirty hack to make dyncall not fail
+ sed -i -e 's/-Werror=missing-prototypes//' Makefile || die
+ sed -i -e 's/-Werror=missing-declarations//' Makefile || die
+ sed -i -e 's/-Werror=strict-prototypes//' Makefile || die
+
+ # more dirty hack to allow building with newer gcc
+ sed -i -e 's/-Werror=implicit-function-declaration//' Makefile || die
+ sed -i -e 's/-Werror=nested-externs//' Makefile || die
}
src_compile() {
- MAKEOPTS=-j1 emake
+ emake -j1 || die
}
src_test() {
- MAKEOPTS=-j1 emake test
+ emake -j1 test || die
}
src_install() {