aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-strategy/wyrmsun/Manifest1
-rw-r--r--games-strategy/wyrmsun/metadata.xml11
-rw-r--r--games-strategy/wyrmsun/wyrmsun-2.7.1.ebuild41
3 files changed, 53 insertions, 0 deletions
diff --git a/games-strategy/wyrmsun/Manifest b/games-strategy/wyrmsun/Manifest
new file mode 100644
index 0000000..b862060
--- /dev/null
+++ b/games-strategy/wyrmsun/Manifest
@@ -0,0 +1 @@
+DIST wyrmsun-2.7.1.tar.gz 267408016 SHA256 fc94c73b2053834cd093cb8cf1ea6e9f5fed44b043472ce6b5b004fdbe9270e9 SHA512 a13681f315fb2d0f3c284b555fe5042f520300857ef8e6f152f9474e26063e2626f61719e25f1269a456195d1d85acd9bf396a51e73b55136e611320b4118512 WHIRLPOOL 98b1272e7a72abb276a5b57b4bd6701b2e5284b9c098d087b6fa45555df08c34185a3260e678b3a5253e39e5eb28d907623c6267de0a24efd75cadd0b43f5b52
diff --git a/games-strategy/wyrmsun/metadata.xml b/games-strategy/wyrmsun/metadata.xml
new file mode 100644
index 0000000..32ccffb
--- /dev/null
+++ b/games-strategy/wyrmsun/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tomboy64@sina.cn</email>
+ <name>Tomboy64</name>
+ </maintainer>
+ <longdescription lang="en">
+ In the Wyrmsun universe a myriad of inhabited planets exist. Humans dwell on Earth, while dwarves inhabit Nidavellir and elves nourish the world of Alfheim. These peoples struggle to carve a place for themselves with their tools of stone, bronze and iron. And perhaps one day they will meet one another, beyond the stars...
+ </longdescription>
+</pkgmetadata>
diff --git a/games-strategy/wyrmsun/wyrmsun-2.7.1.ebuild b/games-strategy/wyrmsun/wyrmsun-2.7.1.ebuild
new file mode 100644
index 0000000..80505ba
--- /dev/null
+++ b/games-strategy/wyrmsun/wyrmsun-2.7.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils gnome2-utils
+
+DESCRIPTION="Strategy game based on history, mythology and fiction"
+HOMEPAGE="https://andrettin.github.io/"
+SRC_URI="https://github.com/Andrettin/Wyrmsun/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="games-engines/wyrmgus"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN/w/W}-${PV}"
+
+src_install() {
+ domenu "linux/${PN}.desktop"
+ newicon -s 128 graphics/ui/icons/wyrmsun_icon_128_background.png wyrmsun.png
+
+ insinto "/usr/share/${PN}/"
+ doins -r graphics maps music scripts sounds translations oaml.defs
+ dodoc license.txt readme.txt
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}