aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/jcpp/jcpp-1.4.12.ebuild')
-rw-r--r--dev-java/jcpp/jcpp-1.4.12.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-java/jcpp/jcpp-1.4.12.ebuild b/dev-java/jcpp/jcpp-1.4.12.ebuild
new file mode 100644
index 0000000..47fb011
--- /dev/null
+++ b/dev-java/jcpp/jcpp-1.4.12.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple vcs-snapshot
+
+DESCRIPTION="A complete, compliant, standalone, pure Java implementation of the C preprocessor"
+HOMEPAGE="https://github.com/shevek/jcpp"
+SRC_URI="https://github.com/shevek/jcpp/archive/1119d798e56ca37f2f976f196e6c27f70f39508b.tar.gz
+ -> jcpp-1.4.12.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="test"
+
+COMMON_DEP="dev-util/findbugs:0
+ dev-java/ant-core:0
+ dev-java/guava:18
+ dev-java/jopt-simple:0
+ dev-java/jsemver:0
+ dev-java/jsr305:0
+ dev-java/junit:4
+ dev-java/slf4j-api:0"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEP}"
+
+JAVA_GENTOO_CLASSPATH="ant-core findbugs guava-18 jopt-simple jsemver jsr305 junit-4 slf4j-api"
+
+src_install() {
+ java-pkg_dojar "${PN}.jar"
+ use doc && java-pkg_dojavadoc target/api
+ use source && java-pkg_dosrc "${P}"/src/{main,test}/java/*
+}