aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/nqp/nqp-2016.04-r4.ebuild')
-rw-r--r--dev-lang/nqp/nqp-2016.04-r4.ebuild20
1 files changed, 15 insertions, 5 deletions
diff --git a/dev-lang/nqp/nqp-2016.04-r4.ebuild b/dev-lang/nqp/nqp-2016.04-r4.ebuild
index 6d3e38e..54d68a5 100644
--- a/dev-lang/nqp/nqp-2016.04-r4.ebuild
+++ b/dev-lang/nqp/nqp-2016.04-r4.ebuild
@@ -13,7 +13,7 @@ if [[ ${PV} == "9999" ]]; then
else
SRC_URI="https://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"
inherit vcs-snapshot
- KEYWORDS=""
+ KEYWORDS="~amd64 ~x86"
fi
DESCRIPTION="Not Quite Perl, a Perl 6 bootstrapping compiler"
@@ -32,14 +32,16 @@ CDEPEND="java? (
moar? ( ~dev-lang/moarvm-${PV}[clang=] )
dev-libs/libffi"
RDEPEND="${CDEPEND}
- java? ( >=virtual/jre-1.7:* )"
+ java? ( >=virtual/jre-1.7 )"
DEPEND="${CDEPEND}
clang? ( sys-devel/clang )
- java? ( >=virtual/jdk-1.7:* )
+ java? ( >=virtual/jdk-1.7 )
dev-lang/perl"
+PATCHES=( "${FILESDIR}/enable-external-jars.patch" )
java_prepare() {
# Don't clean stage0 jars.
+ einfo "Cleaning upstream jars"
java-pkg_clean 3rdparty/
# Don't use jars we just deleted.
@@ -79,6 +81,16 @@ src_test() {
}
src_install() {
+ if use moar; then
+ if use java; then
+ # We need to re-run Configure.pl with only the MoarVM backend,
+ # so we don't overwrite our custom java install.
+ # This has to happen before the installation of nqp's MoarVM bits.
+ # Also, those bits have to get installed before the JVM bits.
+ perl Configure.pl --backend=moar --prefix=/usr || die
+ fi
+ emake DESTDIR="${ED}" install
+ fi
if use java; then
# Set JAVA_PKG_JARDEST early.
java-pkg_init_paths_
@@ -105,8 +117,6 @@ src_install() {
java-pkg_dolauncher ${PN}-j --main ${PN}
dosym ${PN}-j /usr/bin/${PN}
dobin tools/jvm/eval-client.pl
- else
- emake DESTDIR="${ED}" install
fi
dodoc CREDITS README.pod