summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'enlightenment-niifaq.txt')
-rw-r--r--enlightenment-niifaq.txt79
1 files changed, 78 insertions, 1 deletions
diff --git a/enlightenment-niifaq.txt b/enlightenment-niifaq.txt
index 8a22a5062a6b..292b01f905bd 100644
--- a/enlightenment-niifaq.txt
+++ b/enlightenment-niifaq.txt
@@ -30,4 +30,81 @@ WARNING:pkgcore:'xelnor' repo at '/var/lib/repo-mirror-ci/repos/xelnor' has unsu
WARNING:pkgcore:'xelnor' repo at '/var/lib/repo-mirror-ci/repos/xelnor' has unsupported profile format: build-id
WARNING:pkgcore:'genthree' repo at '/var/lib/repo-mirror-ci/repos/genthree' has unsupported profile format: profile-bashrcs
WARNING:pkgcore:EAPI 7 isn't fully supported
- * Cache regenerated successfully
+ * ERROR: x11-plugins/edgar-9999 failed (depend phase):
+ * No supported implementation in PYTHON_COMPAT.
+ *
+ * Call stack:
+ * isolated-functions.lib, line 354: called source '/var/lib/repo-mirror-ci/repos/enlightenment-niifaq/x11-plugins/edgar/edgar-9999.ebuild'
+ * edgar-9999.ebuild, line 13: called inherit 'efl' 'python-single-r1'
+ * ebuild-default-functions.lib, line 201: called __internal_inherit 'python-single-r1'
+ * ebuild-daemon.lib, line 78: called __qa_invoke 'source' '/var/lib/repo-mirror-ci/repos/gentoo/eclass/python-single-r1.eclass'
+ * isolated-functions.lib, line 354: called source '/var/lib/repo-mirror-ci/repos/gentoo/eclass/python-single-r1.eclass'
+ * python-single-r1.eclass, line 263: called _python_single_set_globals
+ * python-single-r1.eclass, line 180: called _python_set_impls
+ * ebuild-daemon.bash, line 486: called die
+ *
+ * Working directory: '/usr/lib64/pkgcore/ebd'
+!!! caught exception False while processing ebuild src: x11-plugins/edgar-9999
+ * ERROR: x11-plugins/edgar-9999 failed (depend phase):
+ * No supported implementation in PYTHON_COMPAT.
+ *
+ * Call stack:
+ * isolated-functions.lib, line 354: called source '/var/lib/repo-mirror-ci/repos/enlightenment-niifaq/x11-plugins/edgar/edgar-9999.ebuild'
+ * edgar-9999.ebuild, line 13: called inherit 'efl' 'python-single-r1'
+ * ebuild-default-functions.lib, line 201: called __internal_inherit 'python-single-r1'
+ * ebuild-daemon.lib, line 78: called __qa_invoke 'source' '/var/lib/repo-mirror-ci/repos/gentoo/eclass/python-single-r1.eclass'
+ * isolated-functions.lib, line 354: called source '/var/lib/repo-mirror-ci/repos/gentoo/eclass/python-single-r1.eclass'
+ * python-single-r1.eclass, line 263: called _python_single_set_globals
+ * python-single-r1.eclass, line 180: called _python_set_impls
+ * python-utils-r1.eclass, line 142: called die
+ *
+ * Working directory: '/usr/lib64/pkgcore/ebd'
+Unhandled exception occurred:
+Traceback follows:
+ File "/usr/lib64/python2.7/site-packages/snakeoil/cli/tool.py", line 132, in main
+ exitstatus = func(self.options, self.out, self.err)
+ File "/usr/lib64/python2.7/site-packages/pkgcore/scripts/pmaint.py", line 318, in regen_main
+ ret.append(update_use_local_desc(repo, out, err))
+ File "/usr/lib64/python2.7/site-packages/pkgcore/scripts/pmaint.py", line 190, in update_use_local_desc
+ for p in repo:
+ File "/usr/lib64/python2.7/site-packages/pkgcore/repository/configured.py", line 62, in <genexpr>
+ return (x for x in self.raw_repo.itermatch(restrict, **kwds)
+ File "/usr/lib64/python2.7/site-packages/pkgcore/repository/prototype.py", line 283, in _internal_match
+ pkg = pkg_klass_override(pkg)
+ File "/usr/lib64/python2.7/site-packages/pkgcore/repository/configured.py", line 50, in package_class
+ return self._klass(pkg, **self._get_pkg_kwds(pkg))
+ File "/usr/lib64/python2.7/site-packages/pkgcore/ebuild/repository.py", line 709, in _get_pkg_kwds
+ immutable, enabled, disabled = self._get_pkg_use(pkg)
+ File "/usr/lib64/python2.7/site-packages/pkgcore/ebuild/domain.py", line 515, in get_package_use_unconfigured
+ pre_defaults = [x[1:] for x in pkg.iuse if x[0] == '+']
+ File "/usr/lib64/python2.7/site-packages/pkgcore/package/base.py", line 98, in dynamic_getattr_dict
+ raise_from(MetadataException(self, attr, str(e)))
+ File "/usr/lib64/python2.7/site-packages/pkgcore/package/base.py", line 90, in dynamic_getattr_dict
+ val = functor(self)
+ File "/usr/lib64/python2.7/site-packages/pkgcore/ebuild/ebuild_src.py", line 234, in <lambda>
+ imap(intern, s.data.pop("IUSE", "").split()))
+ File "/usr/lib64/python2.7/site-packages/pkgcore/package/base.py", line 100, in dynamic_getattr_dict
+ raise_from(MetadataException(self, attr, str(e)))
+ File "/usr/lib64/python2.7/site-packages/pkgcore/package/base.py", line 90, in dynamic_getattr_dict
+ val = functor(self)
+ File "/usr/lib64/python2.7/site-packages/pkgcore/package/metadata.py", line 59, in _get_data
+ return self._fetch_metadata()
+ File "/usr/lib64/python2.7/site-packages/pkgcore/ebuild/ebuild_src.py", line 295, in _fetch_metadata
+ return self._parent._get_metadata(self, ebp=ebp, force_regen=force_regen)
+ File "/usr/lib64/python2.7/site-packages/pkgcore/ebuild/ebuild_src.py", line 384, in _get_metadata
+ return self._update_metadata(pkg, ebp=ebp)
+ File "/usr/lib64/python2.7/site-packages/pkgcore/ebuild/ebuild_src.py", line 392, in _update_metadata
+ mydata = my_proc.get_keys(pkg, self._ecache)
+ File "/usr/lib64/python2.7/site-packages/pkgcore/ebuild/processor.py", line 811, in get_keys
+ {"key": receive_key})
+ File "/usr/lib64/python2.7/site-packages/pkgcore/ebuild/processor.py", line 755, in _run_depend_like_phase
+ raise Exception(val)
+
+MetadataException:
+ metadata exception: pkg ebuild src: x11-plugins/edgar-9999, attr iuse
+ error: metadata exception: pkg ebuild src: x11-plugins/edgar-9999, attr data
+ error: False
+ metadata exception: pkg ebuild src: x11-plugins/edgar-9999, attr data
+ error: False
+ False
+ * Cache regen failed with 246