summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/subdownloader/subdownloader-2.0.16_p20120910.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/media-video/subdownloader/subdownloader-2.0.16_p20120910.ebuild b/media-video/subdownloader/subdownloader-2.0.16_p20120910.ebuild
index 422fef5..fd5f083 100644
--- a/media-video/subdownloader/subdownloader-2.0.16_p20120910.ebuild
+++ b/media-video/subdownloader/subdownloader-2.0.16_p20120910.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=4
+PYTHON_DEPEND="2"
+
inherit python eutils
DESCRIPTION="GUI application for automatic downloading/uploading of subtitles for videofiles"
@@ -21,6 +23,15 @@ DEPEND="
dev-python/kaa-metadata"
RDEPEND="${DEPEND}"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs 2 "${S}"/run.py
+}
+
src_install() {
insinto /usr/share/"${PN}"
doins -r cli FileManagement gui languages locale modules run.py