summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-strategy/curseofwar/curseofwar-9999.ebuild29
-rw-r--r--games-strategy/curseofwar/metadata.xml9
2 files changed, 38 insertions, 0 deletions
diff --git a/games-strategy/curseofwar/curseofwar-9999.ebuild b/games-strategy/curseofwar/curseofwar-9999.ebuild
new file mode 100644
index 0000000..f6c0468
--- /dev/null
+++ b/games-strategy/curseofwar/curseofwar-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit games git-2
+
+DESCRIPTION="Real Time Strategy Game for Linux"
+HOMEPAGE="https://github.com/a-nikolaev/curseofwar"
+EGIT_REPO_URI="https://github.com/a-nikolaev/${PN}.git"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-shells/bash
+ sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ sys-devel/gcc"
+
+src_configure() {
+ sed -i -e 's/CFLAGS\ \ =/CFLAGS\ \ \+=/' Makefile || \
+ die "couldn't patch Makefil CFLAGS"
+ sed -i -e 's/LDFLAGS\ =/LDFLAGS\ \+=/' Makefile || \
+ die "couldn't patch Makefil LDFLAGS"
+}
diff --git a/games-strategy/curseofwar/metadata.xml b/games-strategy/curseofwar/metadata.xml
new file mode 100644
index 0000000..f79ee1e
--- /dev/null
+++ b/games-strategy/curseofwar/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ThyArmageddon+Gentoo@Gmail.com</email>
+ <name>Elijah El Lazkani</name>
+ </maintainer>
+ <longdescription lang="en">This is a fast-paced action strategy game for Linux implemented using ncurses user interface.</longdescription>
+</pkgmetadata>