summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/udevil/udevil-0.2.7.ebuild')
-rw-r--r--sys-apps/udevil/udevil-0.2.7.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/sys-apps/udevil/udevil-0.2.7.ebuild b/sys-apps/udevil/udevil-0.2.7.ebuild
deleted file mode 100644
index 5334f85..0000000
--- a/sys-apps/udevil/udevil-0.2.7.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-
-inherit eutils autotools user
-
-DESCRIPTION="Linux program to mount and unmount removable devices without a password"
-HOMEPAGE="http://ignorantguru.github.com/udevil/"
-SRC_URI="https://github.com/IgnorantGuru/${PN}/raw/master/packages/${PV}/${P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="
- >=app-shells/bash-4.0
- >=sys-fs/udev-143
- sys-libs/glibc
- virtual/acl"
-DEPEND="${RDEPEND}
- dev-util/intltool
- sys-devel/gettext
- virtual/pkgconfig"
-
-pkg_setup() {
- enewgroup plugdev
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-flags.patch"
- eautoreconf
-}
-
-src_configure() {
- econf --with-setfacl-prog=/bin/setfacl
-}
-
-src_install() {
- emake DESTDIR="${ED}" install
- doman man/udevil.1
- dodoc AUTHORS ChangeLog README
- fowners root:plugdev /usr/bin/udevil
- fperms 4754 /usr/bin/udevil
-}
-
-pkg_postinst() {
- echo
- elog "Please add your user to the plugdev group"
- elog "to be able to use ${PN} as a user"
- echo
-}