aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAstroFloyd <AstroFloyd@gmail.com>2013-01-14 18:29:06 +0100
committerAstroFloyd <AstroFloyd@gmail.com>2013-01-14 18:29:06 +0100
commit921118c7d6f6a490f28556eeab598159d6c46785 (patch)
tree8430d7bdb3ee87919f3b0f98afa5eb17da6d9dcd /dev-libs
parentUpdated madwifi-ng to 0.9.4.4180.20120502 (diff)
downloadAstroFloyd-921118c7d6f6a490f28556eeab598159d6c46785.tar.gz
AstroFloyd-921118c7d6f6a490f28556eeab598159d6c46785.tar.bz2
AstroFloyd-921118c7d6f6a490f28556eeab598159d6c46785.zip
Added files for dev-libs/intel-common, copied from portage
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/intel-common/ChangeLog30
-rw-r--r--dev-libs/intel-common/intel-common-13.0.1.117.ebuild57
-rw-r--r--dev-libs/intel-common/metadata.xml12
3 files changed, 99 insertions, 0 deletions
diff --git a/dev-libs/intel-common/ChangeLog b/dev-libs/intel-common/ChangeLog
new file mode 100644
index 0000000..80ee592
--- /dev/null
+++ b/dev-libs/intel-common/ChangeLog
@@ -0,0 +1,30 @@
+# ChangeLog for dev-libs/intel-common
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/intel-common/ChangeLog,v 1.6 2012/12/10 21:15:31 jlec Exp $
+
+ 10 Dec 2012; Justin Lecher <jlec@gentoo.org> intel-common-13.0.1.117.ebuild:
+ Manpagges are handled in the eclass
+
+*intel-common-13.0.1.117 (10 Dec 2012)
+
+ 10 Dec 2012; Justin Lecher <jlec@gentoo.org> +intel-common-13.0.1.117.ebuild,
+ metadata.xml:
+ Version BUmp
+
+ 14 Nov 2012; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml:
+ Removing myself from maintainer
+
+*intel-common-13.0.0.079-r1 (28 Oct 2012)
+
+ 28 Oct 2012; Justin Lecher <jlec@gentoo.org>
+ +intel-common-13.0.0.079-r1.ebuild:
+ Mask installation from revdep-rebuild ,#438820
+
+ 20 Sep 2012; Justin Lecher <jlec@gentoo.org> intel-common-13.0.0.079.ebuild:
+ Avoid double prefix
+
+*intel-common-13.0.0.079 (16 Sep 2012)
+
+ 16 Sep 2012; Justin Lecher <jlec@gentoo.org> +intel-common-13.0.0.079.ebuild,
+ +metadata.xml:
+ Imported from sci overlay; new package containing common libs, #297542
diff --git a/dev-libs/intel-common/intel-common-13.0.1.117.ebuild b/dev-libs/intel-common/intel-common-13.0.1.117.ebuild
new file mode 100644
index 0000000..ede819b
--- /dev/null
+++ b/dev-libs/intel-common/intel-common-13.0.1.117.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/intel-common/intel-common-13.0.1.117.ebuild,v 1.2 2012/12/10 21:15:31 jlec Exp $
+
+EAPI=4
+
+INTEL_DPN=parallel_studio_xe
+INTEL_DID=2872
+INTEL_DPV=2013_update1
+INTEL_SUBDIR=composerxe
+
+inherit intel-sdp
+
+DESCRIPTION="Common libraries and utilities needed for Intel compilers and libraries"
+HOMEPAGE="http://software.intel.com/en-us/articles/intel-compilers/"
+
+IUSE="+compiler"
+
+CHECKREQS_DISK_BUILD=325M
+
+pkg_setup() {
+ einfo ${INTEL_SDP_EDIR}
+ INTEL_BIN_RPMS="openmp openmp-devel"
+ INTEL_DAT_RPMS="compilerpro-common"
+ if use compiler; then
+ INTEL_BIN_RPMS+=" compilerpro-devel sourcechecker-devel"
+ INTEL_DAT_RPMS+=" compilerpro-vars sourcechecker-common"
+ fi
+ intel-sdp_pkg_setup
+}
+
+src_install() {
+ intel-sdp_src_install
+ local path rootpath ldpath arch fenv=35intelsdp
+ cat > ${fenv} <<-EOF
+ NLSPATH=${INTEL_SDP_EDIR}/lib/locale/en_US/%N
+ INTEL_LICENSE_FILE="${INTEL_SDP_EDIR}"/licenses:"${EPREFIX}/opt/intel/license"
+ EOF
+ for arch in ${INTEL_ARCH}; do
+ path=${path}:${INTEL_SDP_EDIR}/bin/${arch}:${INTEL_SDP_EDIR}/mpirt/bin/${arch}
+ rootpath=${rootpath}:${INTEL_SDP_EDIR}/bin/${arch}:${INTEL_SDP_EDIR}/mpirt/bin/${arch}
+ ldpath=${ldpath}:${INTEL_SDP_EDIR}/compiler/lib/${arch}:${INTEL_SDP_EDIR}/mpirt/lib/${arch}
+ done
+ cat >> ${fenv} <<-EOF
+ PATH=${path#:}
+ ROOTPATH=${rootpath#:}
+ LDPATH=${ldpath#:}
+ EOF
+
+ doenvd ${fenv}
+
+ cat >> "${T}"/40-${PN} <<- EOF
+ SEARCH_DIRS_MASK="${INTEL_SDP_EDIR}"
+ EOF
+ insinto /etc/revdep-rebuild/
+ doins "${T}"/40-${PN}
+}
diff --git a/dev-libs/intel-common/metadata.xml b/dev-libs/intel-common/metadata.xml
new file mode 100644
index 0000000..269cea1
--- /dev/null
+++ b/dev-libs/intel-common/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ This package contains the core files to be installed for the Intel
+ compilers and libraries. Probably useless if installed standalone.
+</longdescription>
+ <use>
+ <flag name="compiler">Install the libraries needed for the icc and ifort compilers</flag>
+ </use>
+</pkgmetadata>