aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAstroFloyd <AstroFloyd@gmail.com>2013-08-26 16:20:54 +0200
committerAstroFloyd <AstroFloyd@gmail.com>2013-08-26 16:20:54 +0200
commita1737bbbf5af76ac9dae65c95494e33ed0921254 (patch)
treeb8be3d46c325bc5bd220b89d653ec91f42baf5a4 /sci-astronomy
parentVersion bump to sci-libs/libsufr-0.5.3.ebuild (diff)
downloadAstroFloyd-a1737bbbf5af76ac9dae65c95494e33ed0921254.tar.gz
AstroFloyd-a1737bbbf5af76ac9dae65c95494e33ed0921254.tar.bz2
AstroFloyd-a1737bbbf5af76ac9dae65c95494e33ed0921254.zip
New ebuild: sci-astronomy/libthesky-0.0.1
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/libthesky/ChangeLog10
-rw-r--r--sci-astronomy/libthesky/Manifest4
-rw-r--r--sci-astronomy/libthesky/libthesky-0.0.1.ebuild29
-rw-r--r--sci-astronomy/libthesky/metadata.xml9
4 files changed, 52 insertions, 0 deletions
diff --git a/sci-astronomy/libthesky/ChangeLog b/sci-astronomy/libthesky/ChangeLog
new file mode 100644
index 0000000..e14d373
--- /dev/null
+++ b/sci-astronomy/libthesky/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-astronomy/libthesky
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*libthesky-0.0.1 (26 Aug 2013)
+
+ 26 Aug 2013; AstroFloyd <AstroFloyd@gmail.com> +libthesky-0.0.1.ebuild,
+ +metadata.xml:
+ New ebuild
+
diff --git a/sci-astronomy/libthesky/Manifest b/sci-astronomy/libthesky/Manifest
new file mode 100644
index 0000000..cedf867
--- /dev/null
+++ b/sci-astronomy/libthesky/Manifest
@@ -0,0 +1,4 @@
+DIST libthesky-0.0.1.tar.gz 1499038 SHA256 2e708ab35867fb0b1974d598e61ccea4e7ecedd806346f4495f940a625525c15 SHA512 c0e9a9f34fc3ef9affd2bfd199c04680208d52e0bf928c488fe80a1df8cd96f3edb89d61c323560dc8e12bda1f616d67b7533d574876b95626d9612e5b54459f WHIRLPOOL 4b4f33ae3bf6a268292d9b22b9f68d77badd2ae7a0a1468ad3c4601c3e35bce01953bf2b720f0d47336d8492fe2cd793aa7f41403dcfa835696e0e531b8e27b3
+EBUILD libthesky-0.0.1.ebuild 613 SHA256 6dc25531b5f3ec68b1196af62cb1a6cc05e8579ce6519037bb8de68553179a07 SHA512 f864fe14c2b8d6aec3ffeb1e7fb2f3e295d722ff2183a24b5cc23f0c936c3c4761676a3a8fab087b97ff3b67f09574c5172b944505890d5a2c21a2ceb8929226 WHIRLPOOL 26e38a003ee42aebea547dc237fe80cd33c99e9588600e486beaa66bc72d62c39cba4d54c8f5dfae8efeca34ebd63a8b95eefb1c2f141cf506d36ce89cd69695
+MISC ChangeLog 261 SHA256 dc2a66af5205880f20a91b3ef98e04c7b2da687fa2cb9e75637c47b71c3dc09d SHA512 db1f1bcaa3475aa8e88e635999d429643adbe31e6ecb8979ca8f1e5f199fe5a205a774095c9f59a42f3a614a50737f8ec255b6532ddb09a41250188a3af06c05 WHIRLPOOL 5c7594fea391cecadc0fae648833fc0e5f7920b2e666af10a8dfbe856ba4f639c6fb0ebe1800e47ce534685bddde0c0727a33e2ac63b7180ecb6002aa951ede5
+MISC metadata.xml 260 SHA256 241a25a760d35cb7f521bff34c938ff9ca509a8301e599962908753654ea4997 SHA512 43211c1fa5156d2af73ffb031e1c6ea2997a7e4c0ecba85e082c1d5aa2083d1b8a26bd0af1cf0544f95f8460e8c2c4058da882b2865eb2a500ea55c05d056c42 WHIRLPOOL 0c162d3d989257c4d7edd2929d9ef7a5f682011b1df44b46759f1ef92366299c6bf7cae822bd2063083acc1e7b6dfbec32918983d86179be22653711e24e21e9
diff --git a/sci-astronomy/libthesky/libthesky-0.0.1.ebuild b/sci-astronomy/libthesky/libthesky-0.0.1.ebuild
new file mode 100644
index 0000000..726277a
--- /dev/null
+++ b/sci-astronomy/libthesky/libthesky-0.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit cmake-utils fortran-2
+
+DESCRIPTION="Fortran library to compute positions of celestial bodies"
+HOMEPAGE="http://libthesky.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="virtual/fortran
+>=sci-libs/libsufr-0.5.3"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use static-libs CREATE_STATICLIB)
+ )
+ cmake-utils_src_configure
+}
+
+DOCS="CHANGELOG README VERSION"
diff --git a/sci-astronomy/libthesky/metadata.xml b/sci-astronomy/libthesky/metadata.xml
new file mode 100644
index 0000000..57a1b19
--- /dev/null
+++ b/sci-astronomy/libthesky/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-astronomy</herd>
+ <maintainer>
+ <email>AstroFloyd@gmail.com</email>
+ <name>AstroFloyd</name>
+ </maintainer>
+</pkgmetadata>