aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAstroFloyd <AstroFloyd@gmail.com>2015-06-19 10:16:32 +0200
committerAstroFloyd <AstroFloyd@gmail.com>2015-06-19 10:16:32 +0200
commitd61f61d5bcc68bd9a054665658810e1b0b6c36af (patch)
treeb91cd9dbcdbdaa3a5f2171cafd322c7e4c3ef74e /x11-libs/gtk-fortran/gtk-fortran-2.9999-r1.ebuild
parentRemoved obsolete sys-devel/gcc-4.7.2-r99 from repo (diff)
downloadAstroFloyd-d61f61d5bcc68bd9a054665658810e1b0b6c36af.tar.gz
AstroFloyd-d61f61d5bcc68bd9a054665658810e1b0b6c36af.tar.bz2
AstroFloyd-d61f61d5bcc68bd9a054665658810e1b0b6c36af.zip
Revision bump to x11-libs/gtk-fortran v2.9999-r1 and x11-libs/gtk-fortran v3.9999-r1
Package-Manager: portage-2.2.18
Diffstat (limited to 'x11-libs/gtk-fortran/gtk-fortran-2.9999-r1.ebuild')
-rw-r--r--x11-libs/gtk-fortran/gtk-fortran-2.9999-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11-libs/gtk-fortran/gtk-fortran-2.9999-r1.ebuild b/x11-libs/gtk-fortran/gtk-fortran-2.9999-r1.ebuild
new file mode 100644
index 0000000..fa3dfaa
--- /dev/null
+++ b/x11-libs/gtk-fortran/gtk-fortran-2.9999-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit cmake-utils fortran-2 git-2
+
+DESCRIPTION="Cross-platform Fortran binding to create GUIs using GTK+"
+HOMEPAGE="https://github.com/jerryd/gtk-fortran/wiki"
+
+LICENSE="GPL-3"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+
+EGIT_REPO_URI="https://github.com/jerryd/gtk-fortran.git"
+
+DEPEND=">=x11-libs/gtk+-2.24:2 x11-libs/cairo x11-libs/gdk-pixbuf"
+RDEPEND="${DEPEND}"
+
+# Cannot do a parallel build:
+src_compile() {
+ cd "${CMAKE_BUILD_DIR}"
+ emake -j1 VERBOSE=1 || die
+}