aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/skypeforlinux')
-rw-r--r--net-im/skypeforlinux/ChangeLog5
-rw-r--r--net-im/skypeforlinux/Manifest4
-rw-r--r--net-im/skypeforlinux/metadata.xml20
-rw-r--r--net-im/skypeforlinux/skypeforlinux-8.56.0.103-r2.ebuild102
4 files changed, 131 insertions, 0 deletions
diff --git a/net-im/skypeforlinux/ChangeLog b/net-im/skypeforlinux/ChangeLog
new file mode 100644
index 0000000..df64079
--- /dev/null
+++ b/net-im/skypeforlinux/ChangeLog
@@ -0,0 +1,5 @@
+*skypeforlinux-8.56.0.103-r2 (26 Mar 2020)
+
+ 26 Mar 2020; AstroFloyd <AstroFloyd@gmail.com> +metadata.xml,
+ +skypeforlinux-8.56.0.103-r2.ebuild:
+ net-im/skypeforlinux: add v8.56.0.103-r2 to repo for use w/o USER_NS
diff --git a/net-im/skypeforlinux/Manifest b/net-im/skypeforlinux/Manifest
new file mode 100644
index 0000000..cbbad5f
--- /dev/null
+++ b/net-im/skypeforlinux/Manifest
@@ -0,0 +1,4 @@
+DIST skypeforlinux_8.56.0.103-1.x86_64.rpm 107196663 BLAKE2B 987d35fe670e0902db0d43bea1071f24e893613ec80db3fd2d41c1080f3ea1178a449687fe85384dad93955990afadf7144af31aec0f188e7da5d0ff85c51aca SHA512 2760cdcc0afbf626b603d6716fba201b726f58d5be4e17a90fff271769c99c5a9802b27d7c88d4307ddbd5844c0d705c5dd6ecb9834b7b754f2c5d987d6cbed0
+EBUILD skypeforlinux-8.56.0.103-r2.ebuild 3314 BLAKE2B 05d310eecd9d4cab8f7cf724b8b8ecbbcd1844b39fbfe3fd6d2f48175bad402aa43b14c126528f2417cffd37210376b9b6a7acb67644f30698443a3fa63a1b8f SHA512 2751fc49a06bef341bc178becafa8ee70d9892a5115572f807e0eba8bc56a18bad14699cda8a11a20e0e5cba36c77dc794395583d3a710531d5274c7fa8efd07
+MISC ChangeLog 218 BLAKE2B c8de340406a815d249e2713be36980dc1290ba0191dd497859dcf279fe9ee19a491d430c5e0c1d7384913bf9c1fdc86d0d81c4952ea184cddfda30f5e211022f SHA512 ceb97c5f8aeb9c61add5e2ce08d10e4c98996a7269d7805a8c5fb1aad40082d49d2ce134e051a1aed3e145866afe56979c282afe8c1c71d319c5122de32f5f01
+MISC metadata.xml 809 BLAKE2B d66696f319d1d5800a2fba9f294c491f49ed2834d5e6265d9ccc1d28e4449547119883f046e09a2c6fb2c5ef717c20dd1a37210d0269ce9498c0f79d99545c18 SHA512 3b6432baf6f647e87cc27dd34a5f54fad60762b8904fa290d7aca556f19a4fcfe17200c1f05a4ad29e67a22b99f2a115b5800fb635579fcbe86591ce6d81372a
diff --git a/net-im/skypeforlinux/metadata.xml b/net-im/skypeforlinux/metadata.xml
new file mode 100644
index 0000000..1dda8f8
--- /dev/null
+++ b/net-im/skypeforlinux/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>onigino@protonmail.com</email>
+ <name>Gino McCarty</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>jano.vesely@gmail.com</email>
+ <name>Jan Vesely</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="pax_kernel">Triggers a paxmarking of the main skype binary</flag>
+ </use>
+ <longdescription>Skype is for doing things together, whenever you're apart. Skype's text, voice and video make it simple to share experiences with the people that matter to you, wherever they are.</longdescription>
+</pkgmetadata>
diff --git a/net-im/skypeforlinux/skypeforlinux-8.56.0.103-r2.ebuild b/net-im/skypeforlinux/skypeforlinux-8.56.0.103-r2.ebuild
new file mode 100644
index 0000000..941d1e6
--- /dev/null
+++ b/net-im/skypeforlinux/skypeforlinux-8.56.0.103-r2.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit chromium-2 desktop pax-utils rpm multilib-build xdg
+
+DESCRIPTION="Instant messaging client, with support for audio and video"
+HOMEPAGE="https://www.skype.com/"
+SRC_URI="https://repo.skype.com/rpm/stable/${PN}_${PV}-1.x86_64.rpm"
+
+LICENSE="Skype-TOS MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 Boost-1.0 ISC CC-BY-SA-3.0 CC0-1.0 openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="pax_kernel"
+
+S="${WORKDIR}"
+QA_PREBUILT="*"
+RESTRICT="mirror bindist strip" #299368
+
+RDEPEND="
+ app-crypt/libsecret[${MULTILIB_USEDEP}]
+ dev-libs/atk[${MULTILIB_USEDEP}]
+ dev-libs/expat[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr[${MULTILIB_USEDEP}]
+ dev-libs/nss[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
+ media-libs/freetype:2[${MULTILIB_USEDEP}]
+ media-libs/libv4l[${MULTILIB_USEDEP}]
+ net-print/cups[${MULTILIB_USEDEP}]
+ sys-apps/dbus[${MULTILIB_USEDEP}]
+ sys-devel/gcc[cxx]
+ virtual/ttf-fonts
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXScrnSaver[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libxcb[${MULTILIB_USEDEP}]
+ x11-libs/libxkbfile[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]"
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ rpm_src_unpack ${A}
+}
+
+src_prepare() {
+ default
+ sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EPREFIX}/opt/skypeforlinux/skypeforlinux!" \
+ -i usr/bin/skypeforlinux || die
+ sed -e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
+ -e "/^OnlyShowIn=/d" \
+ -i usr/share/applications/skypeforlinux.desktop || die
+}
+
+src_install() {
+ dodir /opt
+ cp -a usr/share/skypeforlinux "${D}"/opt || die
+
+ dobin usr/bin/skypeforlinux
+
+ dodoc usr/share/skypeforlinux/*.html
+ dodoc -r usr/share/doc/skypeforlinux/.
+ # symlink required for the "Help->3rd Party Notes" menu entry (otherwise frozen skype -> xdg-open)
+ dosym ${PF} usr/share/doc/skypeforlinux
+
+ doicon usr/share/pixmaps/skypeforlinux.png
+
+ local res
+ for res in 16 32 256 512; do
+ newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
+ done
+
+ domenu usr/share/applications/skypeforlinux.desktop
+
+ if use pax_kernel; then
+ pax-mark -m "${ED}"/opt/skypeforlinux/skypeforlinux
+ pax-mark -m "${ED}"/opt/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
+ ewarn "You have set USE=pax_kernel meaning that you intend to run"
+ ewarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+ ewarn "the ${PN} binary itself and this *may* lead to breakage! If"
+ ewarn "you suspect that ${PN} is being broken by this modification,"
+ ewarn "please open a bug."
+ fi
+}