aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/googlecl/googlecl-0.9.15-r1.ebuild')
-rw-r--r--net-misc/googlecl/googlecl-0.9.15-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/googlecl/googlecl-0.9.15-r1.ebuild b/net-misc/googlecl/googlecl-0.9.15-r1.ebuild
new file mode 100644
index 0000000..24c828e
--- /dev/null
+++ b/net-misc/googlecl/googlecl-0.9.15-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_DEPEND="2:2.7"
+
+inherit distutils-r1
+
+DESCRIPTION="Command line tools for the Google Data APIs"
+HOMEPAGE="https://github.com/vinitkumar/googlecl"
+SRC_URI="https://github.com/vinitkumar/${PN}/archive/v${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~arm-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ dev-python/gdata
+"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_install() {
+ distutils_src_install
+
+ dodoc changelog || die "dodoc failed"
+ doman docs/man/*.1 || die "doman failed"
+}