aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/pg2plplot/pg2plplot-5.12.0.ebuild')
-rw-r--r--sci-libs/pg2plplot/pg2plplot-5.12.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-libs/pg2plplot/pg2plplot-5.12.0.ebuild b/sci-libs/pg2plplot/pg2plplot-5.12.0.ebuild
new file mode 100644
index 0000000..6f0ec93
--- /dev/null
+++ b/sci-libs/pg2plplot/pg2plplot-5.12.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CMAKE_VERBOSE=1
+
+inherit cmake-utils fortran-2
+
+DESCRIPTION="Assist the transition from PGPlot to PLplot in Fortran programs"
+HOMEPAGE="http://pg2plplot.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X png postscript static-libs"
+
+DEPEND="virtual/fortran
+ sci-libs/plplot[fortran]"
+
+# If USE="png" or "postscript", ensure PLplot has USE="cairo":
+RDEPEND="${DEPEND}
+ sci-libs/plplot[fortran,X?]
+ png? ( sci-libs/plplot[cairo] )
+ postscript? ( sci-libs/plplot[cairo] )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use static-libs CREATE_STATICLIB)
+ )
+ cmake-utils_src_configure
+}
+
+DOCS="CHANGELOG README VERSION"