summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDustin Polke <DuPol@gmx.de>2017-01-31 20:25:05 +0100
committerDustin Polke <DuPol@gmx.de>2017-01-31 20:25:38 +0100
commit81732c269644d8da1359dbfd3860348994a22908 (patch)
tree8087256a368984b4f85013cc4941e6f4e060e488 /net-analyzer/tcpreplay/tcpreplay-3.4.4-r1.ebuild
parent[media-video/r5u87x-userspace] Fix repoman complaint about metadata. (diff)
downloadDuPol-81732c269644d8da1359dbfd3860348994a22908.tar.gz
DuPol-81732c269644d8da1359dbfd3860348994a22908.tar.bz2
DuPol-81732c269644d8da1359dbfd3860348994a22908.zip
[net-analyzer/tcpreplay] Drop old.
Diffstat (limited to 'net-analyzer/tcpreplay/tcpreplay-3.4.4-r1.ebuild')
-rw-r--r--net-analyzer/tcpreplay/tcpreplay-3.4.4-r1.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/net-analyzer/tcpreplay/tcpreplay-3.4.4-r1.ebuild b/net-analyzer/tcpreplay/tcpreplay-3.4.4-r1.ebuild
deleted file mode 100644
index 3dd1c34..0000000
--- a/net-analyzer/tcpreplay/tcpreplay-3.4.4-r1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpreplay/tcpreplay-3.4.4-r1.ebuild,v 1.3 2011/03/21 08:12:16 tomka Exp $
-
-EAPI="2"
-
-inherit eutils
-
-DESCRIPTION="replay saved tcpdump or snoop files at arbitrary speeds"
-HOMEPAGE="http://tcpreplay.synfin.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~sparc x86"
-IUSE="debug pcapnav +tcpdump"
-
-DEPEND="
- >=sys-devel/autogen-5.9.8
- dev-libs/libdnet
- >=net-libs/libpcap-0.9
- tcpdump? ( net-analyzer/tcpdump )
- pcapnav? ( net-libs/libpcapnav )"
-
-RDEPEND="${DEPEND}"
-
-: ${TCPREPLAY_NIC:="eth0"}
-: ${TCPREPLAY_NIC2:="$TCPREPLAY_NIC}"}
-
-src_prepare() {
- echo "We don't use bundled libopts" > libopts/options.h
- epatch "${FILESDIR}"/${P}-crash.patch
-}
-
-src_configure() {
- # By default it uses static linking. Avoid that, bug 252940
- econf --enable-shared \
- --disable-local-libopts \
- --with-testnic="${TCPREPLAY_NIC}" \
- --with-testnic2="${TCPREPLAY_NIC2}" \
- $(use_with tcpdump tcpdump /usr/sbin/tcpdump) \
- $(use_with pcapnav pcapnav-config /usr/bin/pcapnav-config) \
- $(use_enable debug)
-}
-
-src_test() {
- if [[ ! ${EUID} -eq 0 ]]; then
- ewarn "Some tests were disabled due to FEATURES=userpriv"
- ewarn "To run all tests issue the following command as root:"
- ewarn " # make -C ${S}/test"
- make -C test tcpprep || die "self test failed - see ${S}/test/test.log"
- else
- make test || {
- ewarn "Note, that some tests require an iface to be UP. The" ;
- ewarn "default setting is eth0. A different iface can be used by" ;
- ewarn "setting 'TCPREPLAY_NIC' and 'TCPREPLAY_NIC2 variables." ;
- die "self test failed - see ${S}/test/test.log" ; }
- fi
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
- dodoc README docs/{CHANGELOG,CREDIT,HACKING,TODO} || die
-}