summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-plugins/cd-plugins-core/ChangeLog6
-rw-r--r--x11-plugins/cd-plugins-core/cd-plugins-core-3.0.1-r2.ebuild (renamed from x11-plugins/cd-plugins-core/cd-plugins-core-3.0.1-r1.ebuild)2
-rw-r--r--x11-plugins/cd-plugins-core/files/cd-plugins-core-3.0-python_Dbus-r1.patch (renamed from x11-plugins/cd-plugins-core/files/cd-plugins-core-3.0-python_Dbus.patch)6
3 files changed, 10 insertions, 4 deletions
diff --git a/x11-plugins/cd-plugins-core/ChangeLog b/x11-plugins/cd-plugins-core/ChangeLog
index a314119..f94aded 100644
--- a/x11-plugins/cd-plugins-core/ChangeLog
+++ b/x11-plugins/cd-plugins-core/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2017 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 01 Feb 2017; Dustin Polke <DuPol@gmx.de> -cd-plugins-core-3.0.1-r1.ebuild,
+ +cd-plugins-core-3.0.1-r2.ebuild,
+ -files/cd-plugins-core-3.0-python_Dbus.patch,
+ +files/cd-plugins-core-3.0-python_Dbus-r1.patch:
+ Fix python shebang in python patch.
+
31 Jan 2017; Dustin Polke <DuPol@gmx.de> cd-plugins-core-3.0.1-r1.ebuild:
Bump EAPI and port to python-single-r1 eclass to prevent die in global scope,
bug 607564.
diff --git a/x11-plugins/cd-plugins-core/cd-plugins-core-3.0.1-r1.ebuild b/x11-plugins/cd-plugins-core/cd-plugins-core-3.0.1-r2.ebuild
index d9a2cee..d2f4e95 100644
--- a/x11-plugins/cd-plugins-core/cd-plugins-core-3.0.1-r1.ebuild
+++ b/x11-plugins/cd-plugins-core/cd-plugins-core-3.0.1-r2.ebuild
@@ -73,7 +73,7 @@ src_unpack() {
src_prepare() {
cairo-dock_src_prepare
if use python; then
- epatch "${FILESDIR}"/${PN}-${CD_PV_MAJ_MIN}-python_Dbus.patch
+ epatch "${FILESDIR}"/${PN}-${CD_PV_MAJ_MIN}-python_Dbus-r1.patch
cat >> Dbus/interfaces/CMakeLists.txt <<-EOF
add_subdirectory(bash)
add_subdirectory(python)
diff --git a/x11-plugins/cd-plugins-core/files/cd-plugins-core-3.0-python_Dbus.patch b/x11-plugins/cd-plugins-core/files/cd-plugins-core-3.0-python_Dbus-r1.patch
index 575eddd..fb7eb7e 100644
--- a/x11-plugins/cd-plugins-core/files/cd-plugins-core-3.0-python_Dbus.patch
+++ b/x11-plugins/cd-plugins-core/files/cd-plugins-core-3.0-python_Dbus-r1.patch
@@ -60,7 +60,7 @@
+++ b/Dbus/interfaces/bash/CDBashApplet.py.in
@@ -1,4 +1,4 @@
-#!@PYTHON_EXECUTABLE@
-+#!/bin/python
++#!/usr/bin/python
#
# This is a part of the external applets for Cairo-Dock
# Copyright : (C) 2010-2011 by Nochka85, Fabounet and Matttbe
@@ -68,7 +68,7 @@
+++ b/Dbus/interfaces/python/CairoDock.py.in
@@ -1,4 +1,4 @@
-#!@PYTHON_EXECUTABLE@
-+#!/bin/python
++#!/usr/bin/python
#
# This is a part of the Cairo-Dock plug-ins.
# Copyright : (C) 2010-2011 by Fabounet
@@ -76,7 +76,7 @@
+++ b/Dbus/interfaces/python/CDApplet.py.in
@@ -1,4 +1,4 @@
-#!@PYTHON_EXECUTABLE@
-+#!/bin/python
++#!/usr/bin/python
#
# This is a part of the external applets for Cairo-Dock
# Copyright : (C) 2010-2011 by Fabounet