summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/lives/lives-1.4.6.ebuild')
-rw-r--r--media-video/lives/lives-1.4.6.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/media-video/lives/lives-1.4.6.ebuild b/media-video/lives/lives-1.4.6.ebuild
new file mode 100644
index 0000000..0cf4cdb
--- /dev/null
+++ b/media-video/lives/lives-1.4.6.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+inherit eutils autotools
+
+MY_P="LiVES-${PV}"
+DESCRIPTION="LiVES is a Video Editing System"
+HOMEPAGE="http://lives.sf.net"
+SRC_URI="http://www.xs4all.nl/~salsaman/lives/current/${MY_P}.tar.bz2"
+ # sf.net only has rpms for this version
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="doc libvisual matroska nls ogg static-libs theora" #sdl jack dv"
+
+RDEPEND=">=media-video/mplayer-0.90-r2[encode]
+ >=media-gfx/imagemagick-5.5.6
+ >=dev-lang/perl-5.8.0-r12
+ >=x11-libs/gtk+-2.4:2
+ media-libs/libsdl
+ virtual/ffmpeg
+ virtual/jpeg
+ >=media-sound/sox-12.17.3-r3
+ virtual/cdrtools
+ >=dev-lang/python-2.3.4
+ >=media-video/mjpegtools-1.6.2
+ media-sound/jack-audio-connection-kit
+ sys-libs/libavc1394
+ libvisual? ( media-libs/libvisual )
+ matroska? ( media-video/mkvtoolnix
+ media-libs/libmatroska )
+ ogg? ( media-sound/ogmtools )
+ theora? ( media-libs/libtheora )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.4.2-config_doxygen.patch
+ AT_M4DIR="mk/autoconf" eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable libvisual) \
+ $(use_enable nls) \
+ $(use_enable doc doxygen)
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ dodoc AUTHORS BUGS ChangeLog FEATURES GETTING.STARTED NEWS README
+ # hack to circumvent bug #295293
+ insinto /usr/bin
+ dobin libOSC/sendOSC/sendOSC
+}