summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthoine Bourgeois <anthoine.bourgeois@gmail.com>2012-01-02 15:03:40 +0100
committerAnthoine Bourgeois <anthoine.bourgeois@gmail.com>2012-01-02 15:03:40 +0100
commit3ced35d6f3c939e62b984448d5bd8bef027c3c97 (patch)
tree71610152db9f7e7392a1762fea4096ac1cb7df12
parentblender-2.61: Fix typo, add cycles use desciption. (diff)
downloadaluco-3ced35d6f3c939e62b984448d5bd8bef027c3c97.tar.gz
aluco-3ced35d6f3c939e62b984448d5bd8bef027c3c97.tar.bz2
aluco-3ced35d6f3c939e62b984448d5bd8bef027c3c97.zip
+phoronix-test-suite-3.6.1.ebuild
-rw-r--r--app-benchmarks/phoronix-test-suite/Manifest2
-rw-r--r--app-benchmarks/phoronix-test-suite/phoronix-test-suite-3.6.1.ebuild76
2 files changed, 78 insertions, 0 deletions
diff --git a/app-benchmarks/phoronix-test-suite/Manifest b/app-benchmarks/phoronix-test-suite/Manifest
index 6f7fa42..52bcfed 100644
--- a/app-benchmarks/phoronix-test-suite/Manifest
+++ b/app-benchmarks/phoronix-test-suite/Manifest
@@ -1,5 +1,7 @@
DIST phoronix-test-suite-3.4.0.tar.gz 418224 RMD160 858605ba618cb8c721b68a142db70d9a298ab6d7 SHA1 10be51fc45c077fd73193a8f4bd6c850a9198f84 SHA256 112f394f2bc4b9ea6d472957300d3141fbbf7fd982bc4024597aff941e6d7c03
DIST phoronix-test-suite-3.6.0.tar.gz 431651 RMD160 a8e471a2cad502d89f589de7133ca75fb8bc812b SHA1 4189327380cca588fa469dbb635fab7f1b570038 SHA256 a4ea566e3da36bbcaaf10f1fa3ca21f4089ff961c2ff9b58816236801338aa90
+DIST phoronix-test-suite-3.6.1.tar.gz 432754 RMD160 3b6ccc9034f0b47c569fa7fec2740293cadfa0ea SHA1 c704f053cdd45e34a9ea912ef426f92e441d3dde SHA256 a394ae9529ed1ae37e6c8d0ee0092110c199ab6067c2c61dbb3233525377b738
EBUILD phoronix-test-suite-3.4.0.ebuild 3480 RMD160 21d6467dc0c0b26aea63d3f44fe5e0e8545e14e0 SHA1 e38df570d756a9892f79f38421e5f6223affafeb SHA256 88c6046bf862e36b3cae3b66ffa71eb729fe06af164062bfa3d8fc8e0a547eff
EBUILD phoronix-test-suite-3.6.0.ebuild 2242 RMD160 c8cb88f67f56ef7e4620e0bf3965d8539002ec3d SHA1 9f0586466c7dcf480a325a98f11c51ed08c4a401 SHA256 b01f234283940d443c239f67ed8184692f13f53fa69225f83a5bda3983350d95
+EBUILD phoronix-test-suite-3.6.1.ebuild 2242 RMD160 c8cb88f67f56ef7e4620e0bf3965d8539002ec3d SHA1 9f0586466c7dcf480a325a98f11c51ed08c4a401 SHA256 b01f234283940d443c239f67ed8184692f13f53fa69225f83a5bda3983350d95
MISC metadata.xml 783 RMD160 8b282ed79507ed65205c1374665c292d08e19243 SHA1 ac8c56cddd4c68e7d639a566aa758549bbc2fd2f SHA256 6067a77bc4ffa158a5d3444b84ce21f0c3f3490afc19fcafc4e553c38bb372e6
diff --git a/app-benchmarks/phoronix-test-suite/phoronix-test-suite-3.6.1.ebuild b/app-benchmarks/phoronix-test-suite/phoronix-test-suite-3.6.1.ebuild
new file mode 100644
index 0000000..1eb1b74
--- /dev/null
+++ b/app-benchmarks/phoronix-test-suite/phoronix-test-suite-3.6.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils bash-completion-r1
+
+DESCRIPTION="Phoronix's comprehensive, cross-platform testing and benchmark suite"
+HOMEPAGE="http://www.phoronix-test-suite.com"
+SRC_URI="http://www.phoronix-test-suite.com/download.php?file=${P} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+
+# php 5.3 doesn't have pcre and reflection useflags anymore
+RDEPEND="dev-lang/php:5.3[cli,curl,gd,posix,pcntl,truetype,zip]
+ dev-php/pecl-ps"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i -e "s,export PTS_DIR=\`pwd\`,export PTS_DIR=\"/usr/share/${PN}\"," \
+ phoronix-test-suite
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dodir /usr/share/${PN}
+ insinto /usr/share/${PN}
+
+ doman documentation/man-pages/phoronix-test-suite.1
+ dodoc AUTHORS CHANGE-LOG
+ dohtml -r documentation/
+ doicon pts-core/static/images/phoronix-test-suite.png
+ doicon pts-core/static/images/openbenchmarking.png
+ domenu pts-core/static/phoronix-test-suite.desktop
+ rm -f pts-core/static/phoronix-test-suite.desktop
+
+ doins -r pts-core
+ exeinto /usr/bin
+ doexe phoronix-test-suite
+
+ #fperms a+x /usr/share/${PN}/pts/test-resources/*/*.sh
+ #fperms a+x /usr/share/${PN}/pts/base-test-resources/*/*.sh
+ #fperms a+x /usr/share/${PN}/pts-core/modules/*.sh
+ #fperms a+x /usr/share/${PN}/pts-core/test-libraries/*.sh
+ fperms a+x /usr/share/${PN}/pts-core/static/scripts/root-access.sh
+ fperms a+x /usr/share/${PN}/pts-core/external-test-dependencies/scripts/install-gentoo-packages.sh
+
+ newbashcomp pts-core/static/bash_completion ${PN}
+
+ ewarn
+ ewarn "phoronix-test-suite needs the 'allow_url_fopen' option set to \"On\""
+ ewarn "in your /etc/php/cli-php5.*/php.ini for downloading to work properly."
+ ewarn
+ ewarn "If you upgrade from phoronix-test-suite-2*, you should reinstall all"
+ ewarn "your tests because"
+ ewarn " \$HOME/.phoronix-test-suite/installed-tests/\$TEST_NAME/"
+ ewarn "moves to"
+ ewarn " \$HOME/.phoronix-test-suite/installed-tests/pts/\$TEST_NAME-\$TEST_VERSION/"
+ ewarn "in phoronix-test-suite-3* version. The \$TEST_VERSION can be find in"
+ ewarn "pts-install.xml file."
+ ewarn
+}