summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthoine Bourgeois <anthoine.bourgeois@gmail.com>2011-08-29 17:35:47 +0200
committerAnthoine Bourgeois <anthoine.bourgeois@gmail.com>2011-08-29 17:35:47 +0200
commit98a87e15d94a868d37a7b9704f34f74b6e6a43d5 (patch)
tree26c949d8262f3dcf7e5e984cea65ed7855d49d9b /app-benchmarks/phoronix-test-suite
parent+phoronix-test-suite-3.4.0_beta2 (diff)
downloadaluco-98a87e15d94a868d37a7b9704f34f74b6e6a43d5.tar.gz
aluco-98a87e15d94a868d37a7b9704f34f74b6e6a43d5.tar.bz2
aluco-98a87e15d94a868d37a7b9704f34f74b6e6a43d5.zip
+phoronix-test-suite-3.2.1-r1.ebuild
Remove php5.2 dependency.
Diffstat (limited to 'app-benchmarks/phoronix-test-suite')
-rw-r--r--app-benchmarks/phoronix-test-suite/Manifest1
-rw-r--r--app-benchmarks/phoronix-test-suite/phoronix-test-suite-3.2.1-r1.ebuild113
2 files changed, 114 insertions, 0 deletions
diff --git a/app-benchmarks/phoronix-test-suite/Manifest b/app-benchmarks/phoronix-test-suite/Manifest
index 8aab8e7..8676abd 100644
--- a/app-benchmarks/phoronix-test-suite/Manifest
+++ b/app-benchmarks/phoronix-test-suite/Manifest
@@ -18,6 +18,7 @@ EBUILD phoronix-test-suite-3.2.0_beta2-r2.ebuild 3341 RMD160 abb9cf9cf8b1626d9be
EBUILD phoronix-test-suite-3.2.0_beta2.ebuild 2179 RMD160 605df0c6a1553054561a79571aa384500714999b SHA1 3817d0e0449972a176637b6f46e7a5b263fbba0f SHA256 d0c6bccc4d089141e9dd0e73901982cd539aaa603b90ba2aad035f157405b5f4
EBUILD phoronix-test-suite-3.2.0_beta3.ebuild 3553 RMD160 3abfaae957b3b2a48edba6f76e99c320ba0d7231 SHA1 ffae660feeeb62c5b7c387bf646c03775370c9ae SHA256 90f82ab19b9a6f4e56ac24f93f2a6dc9ae5601cc3384b32ccca404daaa0110c7
EBUILD phoronix-test-suite-3.2.0_beta4.ebuild 3479 RMD160 8df77e35fdc442f70d2dbb0f4260375246d914e0 SHA1 649b2b8a22d9c9af7fa45632db804905382e09f8 SHA256 9491ec157088f3a4dd06c3b43a32848b890bed6fa9351bdb23d6c08da0f07aba
+EBUILD phoronix-test-suite-3.2.1-r1.ebuild 3482 RMD160 33db236ac91e7bc8319fe8cdad66901a83af1b04 SHA1 36929033430bf6acc128c38865853191deadbaf6 SHA256 d63556e58ec28e69433515de7de6fa664a5a06c4d0f0e68f177bcca8f05cde51
EBUILD phoronix-test-suite-3.2.1.ebuild 3564 RMD160 8918ee77789870c4a51259fa970ee6bb7d96d5e2 SHA1 1584f5886999d41e14a04cd9a4b99c2bfdb0132a SHA256 507077939735a772fc827d1c82f7fe10da36a5d60488903afce76dc8e764fa6f
EBUILD phoronix-test-suite-3.4.0_beta1.ebuild 3479 RMD160 9a46c5af7d3f3fdd99f0ff6710f2828fcca43d0e SHA1 6c526e4571d50ccb3f34594f9982971c8e6ba056 SHA256 02525a4dcb51ec9803c2ad8652c03ea1a4a10c5d86a067c9236e78b1f766381a
EBUILD phoronix-test-suite-3.4.0_beta2.ebuild 3397 RMD160 f61dabf125524131c8a2521e069a05e87406251e SHA1 22f175dc0e284aed57ce7a9a41c8bdfd26dfa8fb SHA256 165e20e11c2531b225032554637be614ba112c748fda30c169e06f7de5fbf2ad
diff --git a/app-benchmarks/phoronix-test-suite/phoronix-test-suite-3.2.1-r1.ebuild b/app-benchmarks/phoronix-test-suite/phoronix-test-suite-3.2.1-r1.ebuild
new file mode 100644
index 0000000..70e413f
--- /dev/null
+++ b/app-benchmarks/phoronix-test-suite/phoronix-test-suite-3.2.1-r1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils bash-completion
+
+DESCRIPTION="Phoronix's comprehensive, cross-platform testing and benchmark suite"
+HOMEPAGE="http://www.phoronix-test-suite.com"
+SRC_URI="http://www.phoronix-test-suite.com/download.php?file=${P} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+
+# php 5.3 doesn't have pcre and reflection useflags anymore
+RDEPEND="dev-lang/php:5.3[cli,curl,gd,posix,pcntl,truetype,zip]
+ dev-php5/pecl-ps"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i -e "s,export PTS_DIR=\`pwd\`,export PTS_DIR=\"/usr/share/${PN}\"," \
+ phoronix-test-suite
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dodir /usr/share/${PN}
+ insinto /usr/share/${PN}
+
+ doman documentation/man-pages/phoronix-test-suite.1
+ dodoc AUTHORS CHANGE-LOG COPYING
+ dohtml -r documentation/
+ doicon pts-core/static/images/phoronix-test-suite.png
+ doicon pts-core/static/images/openbenchmarking.png
+ domenu pts-core/static/phoronix-test-suite.desktop
+ rm -f pts-core/static/phoronix-test-suite.desktop
+
+ doins -r pts-core
+ exeinto /usr/bin
+ doexe phoronix-test-suite
+
+ #fperms a+x /usr/share/${PN}/pts/test-resources/*/*.sh
+ #fperms a+x /usr/share/${PN}/pts/base-test-resources/*/*.sh
+ #fperms a+x /usr/share/${PN}/pts-core/modules/*.sh
+ #fperms a+x /usr/share/${PN}/pts-core/test-libraries/*.sh
+ fperms a+x /usr/share/${PN}/pts-core/static/scripts/root-access.sh
+ fperms a+x /usr/share/${PN}/pts-core/external-test-dependencies/scripts/install-gentoo-packages.sh
+
+ dobashcompletion pts-core/static/bash_completion ${PN}
+
+ # Need to fix the cli-php config for downloading to work. Very naughty!
+ local slots
+ local slot
+ if [[ "x${PHP_TARGETS}" == "x" ]] ; then
+ ewarn
+ ewarn "PHP_TARGETS seems empty, php.ini file can't be configure."
+ ewarn "Make sure that PHP_TARGETS in /etc/make.conf is set."
+ ewarn "phoronix-test-suite needs the 'allow_url_fopen' option set to \"On\""
+ ewarn "for downloading to work properly."
+ ewarn
+ else
+ for slot in ${PHP_TARGETS}; do
+ slots+=" ${slot/-/.}"
+ done
+ fi
+
+ for slot in ${slots}; do
+ local PHP_INI_FILE="/etc/php/cli-${slot}/php.ini"
+ if [[ -f ${PHP_INI_FILE} ]] ; then
+ dodir $(dirname ${PHP_INI_FILE})
+ cp ${PHP_INI_FILE} "${D}${PHP_INI_FILE}"
+ sed -e 's|^allow_url_fopen .*|allow_url_fopen = On|g' -i "${D}${PHP_INI_FILE}"
+ else
+ if [[ "x$(eselect php show cli)" == "x${slot}" ]] ; then
+ ewarn
+ ewarn "${slot} hasn't a php.ini file."
+ ewarn "phoronix-test-suite needs the 'allow_url_fopen' option set to \"On\""
+ ewarn "for downloading to work properly."
+ ewarn "Check that your PHP_INI_VERSION is set during ${slot} merge"
+ ewarn
+ else
+ elog
+ elog "${slot} hasn't a php.ini file."
+ elog "phoronix-test-suite may need the 'allow_url_fopen' option set to \"On\""
+ elog "for downloading to work properly if you switch to ${slot}"
+ elog "Check that your PHP_INI_VERSION is set during ${slot} merge"
+ elog
+ fi
+ fi
+ done
+
+ ewarn
+ ewarn "If you upgrade from phoronix-test-suite-2*, you should reinstall all"
+ ewarn "your tests because"
+ ewarn " \$HOME/.phoronix-test-suite/installed-tests/\$TEST_NAME/"
+ ewarn "moves to"
+ ewarn " \$HOME/.phoronix-test-suite/installed-tests/pts/\$TEST_NAME-\$TEST_VERSION/"
+ ewarn "in phoronix-test-suite-3* version. The \$TEST_VERSION can be find in"
+ ewarn "pts-install.xml file."
+ ewarn
+}