summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthoine Bourgeois <anthoine.bourgeois@gmail.com>2011-04-30 23:58:33 +0200
committerAnthoine Bourgeois <anthoine.bourgeois@gmail.com>2011-04-30 23:58:33 +0200
commit8e1329522c3d682e5f34b8dbc11d6e318e0269dd (patch)
tree2f4013dbc7476f33975a4f498e011e355a42f205 /dev-util
parent+phoronix-test-suite-3.2.0_beta2.ebuild (diff)
downloadaluco-8e1329522c3d682e5f34b8dbc11d6e318e0269dd.tar.gz
aluco-8e1329522c3d682e5f34b8dbc11d6e318e0269dd.tar.bz2
aluco-8e1329522c3d682e5f34b8dbc11d6e318e0269dd.zip
+apitrace-1.0.ebuild
basic support (no qt4 gui, no python, ...).
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/apitrace/Manifest2
-rw-r--r--dev-util/apitrace/apitrace-1.0.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-util/apitrace/Manifest b/dev-util/apitrace/Manifest
new file mode 100644
index 0000000..c05ee88
--- /dev/null
+++ b/dev-util/apitrace/Manifest
@@ -0,0 +1,2 @@
+DIST apitrace-apitrace-1.0-0-g5f03103.tar.gz 770989 RMD160 202d9e215779204fd5d7b69b231293cc16864e57 SHA1 289b7b66e9daf7d25aebd9b7ed1d28a0e6f8a79a SHA256 5747e9b9cc39854d32e6100212c55f228ab41577b18f61e70f21b7a410c8e0fc
+EBUILD apitrace-1.0.ebuild 1154 RMD160 94ce450bdf72822ec1f846adbfcfb30929d4eae1 SHA1 0a3c9277b1c39f64b8d73613cbeee353b4793be3 SHA256 7b1b1b67e6ac53f20bb8c324b9145c59ecc380ff24228b828ec1bc0a4c67a5c3
diff --git a/dev-util/apitrace/apitrace-1.0.ebuild b/dev-util/apitrace/apitrace-1.0.ebuild
new file mode 100644
index 0000000..9f3b68c
--- /dev/null
+++ b/dev-util/apitrace/apitrace-1.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+PYTHON_DEPEND="python? 2:2.6"
+inherit eutils toolchain-funcs multilib python
+
+DESCRIPTION="A powerful utility to debug OpenGL and Direct3D graphics applications and drivers, and easily capture the graphics API calls, analyze them and playback traces"
+HOMEPAGE="https://github.com/apitrace/apitrace"
+SRC_URI="https://github.com/apitrace/apitrace/tarball/${PV}/apitrace-${P}-0-g5f03103.tar.gz"
+
+LICENSE="BSD"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE="python" #qt4
+
+#RDEPEND="qt4? ( =x11-libs/qt-gui-4.7*
+# >=dev-libs/qjson-0.5 )"
+
+DEPEND="${RDEPEND}
+ =dev-util/cmake-2.8*
+ =dev-lang/python-2.6*"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_unpack() {
+ unpack ${A}
+ #get_version_component_range
+ S=${WORKDIR}/${PN}-${PN}-5f03103
+ cd ${S}
+}
+
+src_configure() {
+ cmake -H. -Bbuild
+}
+
+src_compile() {
+ make -C build
+}
+
+src_install() {
+ dodoc README TODO || die
+
+ echo $PWD
+ exeinto /usr/bin || die
+ doexe build/glretrace || die
+ doexe build/tracedump || die
+
+ dolib.so build/glxtrace.so || die
+ dolib.a build/libtrace.a || die
+}