summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Kriegner <dominik.kriegner@gmail.com>2021-01-25 13:01:47 +0100
committerDominik Kriegner <dominik.kriegner@gmail.com>2021-01-25 14:54:04 +0100
commitfee0d56b193410b97ef7a01bdb0e44d351f8bd90 (patch)
tree8a9b7ed18678b4ef8b602f55e5ce41474239719a /sci-physics/xrayutilities/xrayutilities-1.7.1.ebuild
parentsci-physics/xrayutilities: update renamed dependencies (diff)
downloadanaximander-fee0d56b193410b97ef7a01bdb0e44d351f8bd90.tar.gz
anaximander-fee0d56b193410b97ef7a01bdb0e44d351f8bd90.tar.bz2
anaximander-fee0d56b193410b97ef7a01bdb0e44d351f8bd90.zip
sci-physics/xrayutilities: bump version and update dependencies
Signed-off-by: Dominik Kriegner <dominik.kriegner@gmail.com> Package-Manager: Portage-3.0.14, Repoman-3.0.2
Diffstat (limited to 'sci-physics/xrayutilities/xrayutilities-1.7.1.ebuild')
-rw-r--r--sci-physics/xrayutilities/xrayutilities-1.7.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-physics/xrayutilities/xrayutilities-1.7.1.ebuild b/sci-physics/xrayutilities/xrayutilities-1.7.1.ebuild
new file mode 100644
index 0000000..a701fc6
--- /dev/null
+++ b/sci-physics/xrayutilities/xrayutilities-1.7.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python{3_6,3_7,3_8,3_9} )
+
+inherit distutils-r1
+
+DESCRIPTION="package with useful scripts for X-ray diffraction physicists"
+HOMEPAGE="http://xrayutilities.sourceforge.io"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="openmp test"
+
+DEPEND=">=dev-python/numpy-1.9
+ >=dev-python/scipy-0.13.0
+ dev-python/h5py"
+RDEPEND="${DEPEND}
+ >sys-devel/gcc-4.2:*[openmp?]
+ test? ( dev-python/pytest )"
+
+DOCS=( README.md CHANGES.txt )
+
+python_configure_all() {
+ if ! use openmp; then
+ mydistutilsargs=( --without-openmp )
+ fi
+}
+
+python_test() {
+ py.test -v
+}