summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorandy <andy@mailbox.tu-berlin.de>2013-10-07 14:03:50 +0200
committerandy <andy@mailbox.tu-berlin.de>2013-10-07 14:03:50 +0200
commit6a2ad60461fe56a811c88b12b438a5fa7113921d (patch)
tree6113518e6f51d48b3628c8b07450c4c046e97be7 /app-misc/khal/khal-9999.ebuild
parentfixed digest for pyCardDAV (diff)
downloadandy-6a2ad60461fe56a811c88b12b438a5fa7113921d.tar.gz
andy-6a2ad60461fe56a811c88b12b438a5fa7113921d.tar.bz2
andy-6a2ad60461fe56a811c88b12b438a5fa7113921d.zip
added khal live-ebuild, but atm very buggish
Diffstat (limited to 'app-misc/khal/khal-9999.ebuild')
-rw-r--r--app-misc/khal/khal-9999.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-misc/khal/khal-9999.ebuild b/app-misc/khal/khal-9999.ebuild
new file mode 100644
index 0000000..a46ae4f
--- /dev/null
+++ b/app-misc/khal/khal-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_USE_WITH="sqlite"
+
+inherit distutils-r1 git-2
+
+DESCRIPTION="CLI calendar application build around CalDAV."
+HOMEPAGE="https://github.com/geier/khal"
+SRC_URI=""
+EGIT_REPO_URI="${HOMEPAGE}"
+
+LICENSE="MIT"
+KEYWORDS=""
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/lxml
+ dev-python/requests
+ dev-python/urwid
+ dev-python/pyxdg
+ dev-python/icalendar
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+EXAMPLES=( khal.conf.sample )
+
+pkg_postinst() {
+ ewarn "Copy and edit the supplied khal.conf.sample file"
+ ewarn "(default location is ~/.config/khal/khal.conf)."
+ ewarn "Beware that only you can access this file,"
+ ewarn "if you have untrusted users on your machine,"
+ ewarn "since the password is stored in cleartext."
+}