summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorandy <andy@mailbox.tu-berlin.de>2013-05-21 02:23:42 +0200
committerandy <andy@mailbox.tu-berlin.de>2013-05-21 02:23:42 +0200
commit576bb1a6906e97435f11d702f667030833ce2af8 (patch)
tree41c2ea0ae7d7c51c5f6b4f9c5260b2ed892640ed /media-libs/rsound
parentadded rainbarf (diff)
downloadandy-576bb1a6906e97435f11d702f667030833ce2af8.tar.gz
andy-576bb1a6906e97435f11d702f667030833ce2af8.tar.bz2
andy-576bb1a6906e97435f11d702f667030833ce2af8.zip
added rsound
Diffstat (limited to 'media-libs/rsound')
-rw-r--r--media-libs/rsound/Manifest2
-rw-r--r--media-libs/rsound/files/fix-vlc.patch13
-rw-r--r--media-libs/rsound/rsound-9999.ebuild60
3 files changed, 75 insertions, 0 deletions
diff --git a/media-libs/rsound/Manifest b/media-libs/rsound/Manifest
new file mode 100644
index 0000000..412d203
--- /dev/null
+++ b/media-libs/rsound/Manifest
@@ -0,0 +1,2 @@
+AUX fix-vlc.patch 587 SHA256 afbd75a6665c7f36a619970e92ac24d4705a64e2b929d13b1f3e7b69ed4fc538 SHA512 5c81d440f22c60cb2ac35b290e6f33d36557888ec09956e328095f63fd03bbb2add6d9f7a701900b24b9d41ce752406007d403acbd3e39ade0ad8cc406c67bc4 WHIRLPOOL 201ff09c6d860b72a598dc2ea4d3f55db9e7acd4753f18a48c571793a43e5667bfb35a640d46a01d92b18c9faa4c32a4d1ef21428b018b3632dab0087a635859
+EBUILD rsound-9999.ebuild 1462 SHA256 5865cdeff521a25e9cf1b896740b82f06617ccba5f33d3438beeb5b784d990ff SHA512 23ec6ceff5bb9fda0cdc73e8151adaede7a7ad1d171b8acbb93856e8c4aaa299860f90702805ca6a3fa51973342adf3e226341ddbe42c8cc792c6319dfd7f167 WHIRLPOOL 568e74b16414f83552f3a5a8a0c7f91afe81f68ba77ba0717f39d4817acffba116cb5bc48730fa5d3572bb0765f6785420fe2f6aa74f4f1f8bb489869dd3ec39
diff --git a/media-libs/rsound/files/fix-vlc.patch b/media-libs/rsound/files/fix-vlc.patch
new file mode 100644
index 0000000..f14e1d4
--- /dev/null
+++ b/media-libs/rsound/files/fix-vlc.patch
@@ -0,0 +1,13 @@
+diff --git a/patches/vlc/rsound-plugin.c b/patches/vlc/rsound-plugin.c
+index 7e11a16..f703f1b 100644
+--- a/patches/vlc/rsound-plugin.c
++++ b/patches/vlc/rsound-plugin.c
+@@ -172,7 +172,7 @@ static int Open( vlc_object_t *p_this )
+ rsd_set_param(p_sys->rd, RSD_FORMAT, &format);
+
+ p_aout->format.i_format = VLC_CODEC_S16N;
+- p_aout->i_nb_samples = 1024; // Just pick something relatively small. Anything is fine.
++ /*p_aout->i_nb_samples = 1024; // Just pick something relatively small. Anything is fine.*/
+ p_aout->pf_play = Play;
+
+ aout_VolumeSoftInit( p_aout );
diff --git a/media-libs/rsound/rsound-9999.ebuild b/media-libs/rsound/rsound-9999.ebuild
new file mode 100644
index 0000000..fd2adb6
--- /dev/null
+++ b/media-libs/rsound/rsound-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+inherit git-2 eutils
+
+DESCRIPTION="RSound is a networked audio system. It allows applications to
+transfer their audio data to a different computer."
+HOMEPAGE="http://www.rsound.org/"
+EGIT_REPO_URI="git://github.com/Themaister/RSound.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="alsa ao jack openal oss portaudio pulseaudio syslog vlc"
+
+RDEPEND="media-libs/libsamplerate
+ alsa? ( media-libs/alsa-lib )
+ ao? ( media-libs/libao )
+ jack? ( media-sound/jack-audio-connection-kit )
+ openal? ( media-libs/openal )
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( media-sound/pulseaudio )
+ syslog? ( virtual/logger )
+ vlc? ( media-video/vlc )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/fix-vlc.patch"
+}
+
+src_configure() {
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --disable-muroar \
+ --disable-roar \
+ $(use_enable alsa) \
+ $(use_enable ao libao) \
+ $(use_enable jack) \
+ $(use_enable openal) \
+ $(use_enable oss) \
+ $(use_enable portaudio) \
+ $(use_enable pulseaudio pulse)
+}
+
+src_compile() {
+ emake || die "emake failed"
+ use alsa && emake -C patches/alsa
+ use vlc && emake -C patches/vlc
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README ChangeLog DOCUMENTATION AUTHORS
+
+ use alsa && emake DESTDIR="${D}" -C patches/alsa install
+ use vlc && emake DESTDIR="${D}" -C patches/vlc install
+}