summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorandy <andy@ndyk.de>2014-03-31 12:47:47 +0200
committerandy <andy@ndyk.de>2014-03-31 12:47:47 +0200
commitfffdc2305408f80c0b170b50e93e16e11a962072 (patch)
tree94ee0eadacf865c366bc72a45a601a4413699cc7 /x11-misc/autorandr/autorandr-9999.ebuild
parentbumped jlink to 4.80e (diff)
downloadandy-fffdc2305408f80c0b170b50e93e16e11a962072.tar.gz
andy-fffdc2305408f80c0b170b50e93e16e11a962072.tar.bz2
andy-fffdc2305408f80c0b170b50e93e16e11a962072.zip
added autorandr
Diffstat (limited to 'x11-misc/autorandr/autorandr-9999.ebuild')
-rw-r--r--x11-misc/autorandr/autorandr-9999.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-misc/autorandr/autorandr-9999.ebuild b/x11-misc/autorandr/autorandr-9999.ebuild
new file mode 100644
index 0000000..f564e56
--- /dev/null
+++ b/x11-misc/autorandr/autorandr-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit git-2 bash-completion-r1 udev
+
+DESCRIPTION="Auto-detect the connect display hardware and load the appropiate X11 setup using xrandr or disper"
+HOMEPAGE="https://github.com/phillipberndt/autorandr"
+SRC_URI=""
+EGIT_REPO_URI="${HOMEPAGE}"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS=""
+IUSE="udev +pm-utils"
+
+DEPEND="udev? ( virtual/udev )
+ pm-utils? ( sys-power/pm-utils )"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ exeinto /usr/bin
+ doexe auto-disper
+ doexe autorandr
+ dodoc README.md
+
+ newbashcomp bash_completion/${PN} ${PN}
+
+ if use udev; then
+ udev_dorules udev/40-monitor-hotplug.rules
+ fi
+
+ if use pm-utils; then
+ exeinto /usr/lib/pm-utils/sleep.d
+ doexe pm-utils/40autorandr
+ fi
+}
+
+pkg_postinst() {
+ udev_reload
+}
+