summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoao Carreira <jfmcarreira@gmail.com>2017-07-27 13:30:26 +0100
committerJoao Carreira <jfmcarreira@gmail.com>2017-07-27 13:30:26 +0100
commitabd45453300607895f119df771255712383770f7 (patch)
tree0f5f24e36a7ffd1a7ef78709c958abbcec00f336
parentmedia-gfx/ktikz: Fix ebuild and metadata (diff)
downloadcarreira-abd45453300607895f119df771255712383770f7.tar.gz
carreira-abd45453300607895f119df771255712383770f7.tar.bz2
carreira-abd45453300607895f119df771255712383770f7.zip
dev-util/eclipse-cpp-bin: remove old versions
-rw-r--r--dev-util/eclipse-cpp-bin/eclipse-cpp-bin-4.5.2.ebuild54
-rw-r--r--dev-util/eclipse-cpp-bin/eclipse-cpp-bin-4.6.3.ebuild (renamed from dev-util/eclipse-cpp-bin/eclipse-cpp-bin-4.6.2.ebuild)0
-rw-r--r--dev-util/eclipse-cpp-bin/files/eclipse-bin-4.546
-rw-r--r--dev-util/eclipse-cpp-bin/files/eclipserc-bin-4.523
4 files changed, 0 insertions, 123 deletions
diff --git a/dev-util/eclipse-cpp-bin/eclipse-cpp-bin-4.5.2.ebuild b/dev-util/eclipse-cpp-bin/eclipse-cpp-bin-4.5.2.ebuild
deleted file mode 100644
index 5bb6727..0000000
--- a/dev-util/eclipse-cpp-bin/eclipse-cpp-bin-4.5.2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils versionator
-
-RNAME="mars"
-SR=2
-
-DESCRIPTION="Eclipse IDE for C/C++"
-HOMEPAGE="http://www.eclipse.org"
-
-SRC_BASE="http://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/${RNAME}/${SR}/eclipse-cpp-${RNAME}-${SR}-linux-gtk"
-
-SRC_URI="
- amd64? ( ${SRC_BASE}-x86_64.tar.gz&r=1 -> ${P}-x86_64.tar.gz )
- x86? ( ${SRC_BASE}.tar.gz&r=1 -> ${P}.tar.gz )
-"
-
-LICENSE="EPL-1.0"
-SLOT="4.5"
-KEYWORDS="~amd64"
-IUSE=""
-
-RDEPEND="
- >=virtual/jdk-1.8
- x11-libs/gtk+:2
-"
-
-S=${WORKDIR}/eclipse
-
-src_install() {
- local dest=/opt/${PN}-${SLOT}
-
- insinto ${dest}
- doins -r features icon.xpm plugins artifacts.xml p2 eclipse.ini configuration dropins
-
- exeinto ${dest}
- doexe eclipse
-
- dohtml -r readme/*
-
- cp "${FILESDIR}"/eclipserc-bin-${SLOT} "${T}" || die
- cp "${FILESDIR}"/eclipse-bin-${SLOT} "${T}" || die
- sed "s@%SLOT%@${SLOT}@" -i "${T}"/eclipse{,rc}-bin-${SLOT} || die
-
- insinto /etc
- newins "${T}"/eclipserc-bin-${SLOT} eclipserc-bin-${SLOT}
-
- newbin "${T}"/eclipse-bin-${SLOT} eclipse-cpp-${SLOT}
- make_desktop_entry "eclipse-cpp-${SLOT}" "Eclipse ${PV}" "${dest}/icon.xpm" "Development;IDE"
-
-}
diff --git a/dev-util/eclipse-cpp-bin/eclipse-cpp-bin-4.6.2.ebuild b/dev-util/eclipse-cpp-bin/eclipse-cpp-bin-4.6.3.ebuild
index a73c089..a73c089 100644
--- a/dev-util/eclipse-cpp-bin/eclipse-cpp-bin-4.6.2.ebuild
+++ b/dev-util/eclipse-cpp-bin/eclipse-cpp-bin-4.6.3.ebuild
diff --git a/dev-util/eclipse-cpp-bin/files/eclipse-bin-4.5 b/dev-util/eclipse-cpp-bin/files/eclipse-bin-4.5
deleted file mode 100644
index 867874c..0000000
--- a/dev-util/eclipse-cpp-bin/files/eclipse-bin-4.5
+++ /dev/null
@@ -1,46 +0,0 @@
-#! /bin/sh
-#
-# Tiny startup wrapper for Eclipse
-#
-# Copyright (c) 2004, Karl Trygve Kalleberg <karltk@gentoo.org>
-# Copyright (c) 2007-2008, Jean-Noël Rivasseau <elvanor@gentoo.org>
-# Copyright (c) 2004-2016, Gentoo Foundation
-#
-# Licensed under the GNU General Public License, version 2
-#
-
-SLOT="%SLOT%"
-
-[ -f "/etc/eclipserc-bin-${SLOT}" ] && . "/etc/eclipserc-bin-${SLOT}"
-[ -f "$HOME/gentoo/.eclipserc" ] && . "$HOME/gentoo/.eclipserc"
-
-ECLIPSE_HOME=${ECLIPSE_HOME:="/opt/eclipse-cpp-bin-%SLOT%"}
-ECLIPSE_BIN="${ECLIPSE_HOME}/eclipse"
-
-if [ ! -x "${ECLIPSE_BIN}" ] ; then
- echo "Failed to find executable '${ECLIPSE_BIN}'" > /dev/stderr
- exit 1
-fi
-
-if [ $(id -u) -eq 0 ] ; then
- echo "Do not run eclipse as root user! Exiting ..." > /dev/stderr
- exit 1
-fi
-
-case "$(java-config -f)" in
- *gcj*)
- export JAVA_PKG_CLASSMAP="${ECLIPSE_HOME}/eclipse.gcjdb"
- ;;
-esac
-
-#eval $(gjl --package "swt-${SLOT}" --get-args)
-
-[ -n "${ECLIPSE_XMS}" ] && VM_ARGS="${VM_ARGS} -Xms${ECLIPSE_XMS}"
-[ -n "${ECLIPSE_XMX}" ] && VM_ARGS="${VM_ARGS} -Xmx${ECLIPSE_XMX}"
-[ -n "${ECLIPSE_PERMSIZE}" ] && VM_ARGS="${VM_ARGS} -XX:PermSize=${ECLIPSE_PERMSIZE}"
-[ -n "${ECLIPSE_MAX_PERMSIZE}" ] && VM_ARGS="${VM_ARGS} -XX:MaxPermSize=${ECLIPSE_MAX_PERMSIZE}"
-
-# Fix for JRE 1.5.
-export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:/usr/lib
-
-exec "${ECLIPSE_BIN}" -vm $(java-config --java) "$@" "${ECLIPSE_USER_ARGS}" --launcher.GTK_version ${GTK_VERSION} -vmargs ${VM_ARGS}
diff --git a/dev-util/eclipse-cpp-bin/files/eclipserc-bin-4.5 b/dev-util/eclipse-cpp-bin/files/eclipserc-bin-4.5
deleted file mode 100644
index 8fcb6b1..0000000
--- a/dev-util/eclipse-cpp-bin/files/eclipserc-bin-4.5
+++ /dev/null
@@ -1,23 +0,0 @@
-# This file specifies some initial Eclipse settings, like memory allowed
-# These settings only affect Eclipse startup and overall configuration
-# Main Eclipse configuration should be done within Eclipse (with the GUI)
-
-GTK_VERSION=2
-
-# Following variables controls the minimal and maximum amounts of memory
-# allocated to Eclipse (respectively).
-# Increase those numbers if you get OutOfMemory errors.
-
-ECLIPSE_XMS=256m
-ECLIPSE_XMX=1024m
-
-# Following variables controls the minimal and maximum amounts of memory
-# allocated to the permanent generation space.
-# This space contains data related to all classes.
-# Thus, if you use a lot of Eclipse plugins, it is recommended to uncomment
-# these variables and even increase it, if you have enough RAM.
-# Else you will get crashes related to OutOfMemory in PermGen exceptions.
-
-#ECLIPSE_PERMSIZE=64m
-#ECLIPSE_MAX_PERMSIZE=128m
-