summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/calyp/Manifest1
-rw-r--r--media-video/calyp/calyp-1.0.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/media-video/calyp/Manifest b/media-video/calyp/Manifest
new file mode 100644
index 0000000..3166902
--- /dev/null
+++ b/media-video/calyp/Manifest
@@ -0,0 +1 @@
+DIST calyp-1.0.0.tar.gz 814173 SHA256 60929a2ed7431b09893c2622c18addfe0c17cde0261c2814b617aa768d1a8815 SHA512 6a1a8ee0395ea0db7d5716a5601d6cf65f42b21f809aca06d2e4555aa2fe862225372462e6db538c35593b5e99dbdf6b0ee2eaffe12ec800c0bc74ccd5c31b2c WHIRLPOOL e871392f2a1a5397a27795bb8b644071b8a329fc2afc770a06fb62fb8c5c7de46a30a78c158711448dfbe690e253c0bfccd095c657b400100d2f22bcf45c84e1
diff --git a/media-video/calyp/calyp-1.0.0.ebuild b/media-video/calyp/calyp-1.0.0.ebuild
new file mode 100644
index 0000000..3f99e78
--- /dev/null
+++ b/media-video/calyp/calyp-1.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils cmake-utils
+
+DESCRIPTION="Calyp is an open-source QT based raw video player"
+HOMEPAGE="https://github.com/pixlra/calyp"
+SRC_URI="https://github.com/pixlra/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT=0
+KEYWORDS="~amd64"
+
+X86_CPU_FEATURES="cpu_flags_x86_sse"
+IUSE="+qt5 ffmpeg opencv -static-libs $X86_CPU_FEATURES"
+
+DEPEND="
+ qt5? (
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ )
+ ffmpeg? ( virtual/ffmpeg )
+ opencv? ( media-libs/opencv )
+"
+
+RDEPEND="
+ !media-video/playuver
+ ${DEPEND}
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_SSE=$(usex cpu_flags_x86_sse)
+ -DUSE_FFMPEG=$(usex ffmpeg)
+ -DUSE_OPENCV=$(usex opencv)
+ -DUSE_STATIC=$(usex static-libs)
+ )
+ cmake-utils_src_configure
+}