summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dropbox-cli/Manifest1
-rw-r--r--net-misc/dropbox-cli/dropbox-cli-1.6.0-r2.ebuild30
-rw-r--r--net-misc/dropbox-cli/files/dropbox-cli-completion2
-rw-r--r--net-misc/dropbox-cli/metadata.xml7
4 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/dropbox-cli/Manifest b/net-misc/dropbox-cli/Manifest
new file mode 100644
index 0000000..976ca47
--- /dev/null
+++ b/net-misc/dropbox-cli/Manifest
@@ -0,0 +1 @@
+DIST dropbox-cli-1.6.0.py.xz 17632 SHA256 0030e948dbc6795fecde32c41a7c0779f3ec5131473fa4039ae9356e7238b3d6 SHA512 06fcbba67031c18fe1840f592d04039a7c78848d6e77ae8cca04881f5f72ada7fb368921e2ae3b92d161e49bf91eae0f41b559a210eacd0dc203c51134597857 WHIRLPOOL a0af611c354474e5bec27796bf07933de64d6bd8f3c04641238c8f5149111daf5b1f93a2b33bdc3c89f5386f7a864e7edfa0d9d784f72a2c2b1db9250bdfa6c7
diff --git a/net-misc/dropbox-cli/dropbox-cli-1.6.0-r2.ebuild b/net-misc/dropbox-cli/dropbox-cli-1.6.0-r2.ebuild
new file mode 100644
index 0000000..b79dbc3
--- /dev/null
+++ b/net-misc/dropbox-cli/dropbox-cli-1.6.0-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1 bash-completion-r1
+
+DESCRIPTION="Cli interface for dropbox (python), part of nautilus-dropbox"
+HOMEPAGE="http://www.dropbox.com/"
+SRC_URI="https://dev.gentoo.org/~hasufell/distfiles/${P}.py.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}
+
+src_install() {
+ newbin ${P}.py ${PN}
+ python_replicate_script "${D}"/usr/bin/${PN}
+ newbashcomp "${FILESDIR}"/${PN}-completion ${PN}
+}
diff --git a/net-misc/dropbox-cli/files/dropbox-cli-completion b/net-misc/dropbox-cli/files/dropbox-cli-completion
new file mode 100644
index 0000000..e1e9251
--- /dev/null
+++ b/net-misc/dropbox-cli/files/dropbox-cli-completion
@@ -0,0 +1,2 @@
+# dropbox-cli completion
+complete -W 'autostart exclude filestatus help lansync ls puburl running start status stop' dropbox-cli
diff --git a/net-misc/dropbox-cli/metadata.xml b/net-misc/dropbox-cli/metadata.xml
new file mode 100644
index 0000000..1383022
--- /dev/null
+++ b/net-misc/dropbox-cli/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>grozin@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>