summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Ulyanov <disinbox@gmail.com>2012-01-15 09:59:55 +0400
committerIgor Ulyanov <disinbox@gmail.com>2012-01-15 09:59:55 +0400
commit783932d74076c8ce070447362ac3684a012d2713 (patch)
tree4da3aeb54eea45cd3d02b909ffeb92fb4ce1c77f /app-benchmarks
parentInitial commit (diff)
downloaddisplacer-783932d74076c8ce070447362ac3684a012d2713.tar.gz
displacer-783932d74076c8ce070447362ac3684a012d2713.tar.bz2
displacer-783932d74076c8ce070447362ac3684a012d2713.zip
glmark2 voidp compile fix patch added, 2011.12 version bump
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/glmark2/Manifest5
-rw-r--r--app-benchmarks/glmark2/files/voidp.patch12
-rw-r--r--app-benchmarks/glmark2/glmark2-2011.08.ebuild50
-rw-r--r--app-benchmarks/glmark2/glmark2-2011.12.ebuild50
4 files changed, 117 insertions, 0 deletions
diff --git a/app-benchmarks/glmark2/Manifest b/app-benchmarks/glmark2/Manifest
new file mode 100644
index 0000000..bc85074
--- /dev/null
+++ b/app-benchmarks/glmark2/Manifest
@@ -0,0 +1,5 @@
+AUX voidp.patch 529 RMD160 82575cf1dab539944fee60372e5bf27716b7b778 SHA1 3ff3d5c56eeec8cc2ccf9e377b26d114116b01e3 SHA256 4e750069179c717f476371c865df8ecd847ef513cfcfdf4c18d2910bc8ce1bb2
+DIST glmark2-2011.08.tar.gz 2147647 RMD160 3268b846c9d5df2b0710b20a807cff2a18f1a75b SHA1 c65b31bdabf44f7638eaf746983e5f55fd579f3f SHA256 42351988a5c5ed31b78dec2423f1a48eb18028b6066d14d6bc903ae20f81f341
+DIST glmark2-2011.12.tar.gz 3725171 RMD160 366797d2f8d8cd3d1adabdeb98346061bd63d0e4 SHA1 14711a77074b5314bdb5a2383bb39929f6d137b7 SHA256 e892b482eb3c98a178c2f7e83e655ea6ad537c3d167a7933a090e7833867f6f9
+EBUILD glmark2-2011.08.ebuild 994 RMD160 711cc2c921a5beba0ea4918d095ba24a94c4286d SHA1 713c597c98465a897d0472e7e79dfa97ca247132 SHA256 9c22359c779b540286b477ad4147a7661e3cee5d4dece5089450eab3b4c0ce68
+EBUILD glmark2-2011.12.ebuild 992 RMD160 35ac0b1284d1b62daa8b38710d562603d7db5c12 SHA1 90e897c5819bb37ee8c8ef9f428f2bf65d8aeebd SHA256 7c7c9ada20f7438f35afa04b0b0bf4afe77b08ff0e1a5a7692a0ebeb7e6f3be8
diff --git a/app-benchmarks/glmark2/files/voidp.patch b/app-benchmarks/glmark2/files/voidp.patch
new file mode 100644
index 0000000..5a269bf
--- /dev/null
+++ b/app-benchmarks/glmark2/files/voidp.patch
@@ -0,0 +1,12 @@
+diff -urN glmark2-2011.08/src/texture.cpp glmark2-2011.08_/src/texture.cpp
+--- glmark2-2011.08/src/texture.cpp 2011-08-17 13:10:15.000000000 +0400
++++ glmark2-2011.08_/src/texture.cpp 2012-01-06 18:41:28.461110906 +0400
+@@ -78,7 +78,7 @@
+ }
+
+ /* Read the image information and data */
+- png_set_read_fn(png_, reinterpret_cast<voidp>(is_ptr.get()), png_read_fn);
++ png_set_read_fn(png_, reinterpret_cast<void*>(is_ptr.get()), png_read_fn);
+
+ png_read_png(png_, info_, png_transforms, 0);
+
diff --git a/app-benchmarks/glmark2/glmark2-2011.08.ebuild b/app-benchmarks/glmark2/glmark2-2011.08.ebuild
new file mode 100644
index 0000000..af8f1aa
--- /dev/null
+++ b/app-benchmarks/glmark2/glmark2-2011.08.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit waf-utils
+
+DESCRIPTION="Opengl test suite"
+HOMEPAGE="https://launchpad.net/glmark2"
+SRC_URI="http://launchpad.net/${PN}/2011.11/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gles2"
+
+RDEPEND="media-libs/libpng
+ media-libs/mesa[gles2?]
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/voidp.patch"
+}
+
+src_prepare() {
+ rm -rf ${S}/src/libpng
+ sed -i -e 's#libpng12#libpng#g' ${S}/wscript ${S}/src/wscript_build || die
+}
+
+src_configure() {
+ : ${WAF_BINARY:="${S}/waf"}
+
+ local myconf
+
+ if use gles2; then
+ myconf += "--enable-glesv2"
+ fi
+
+ # it does not know --libdir specification, dandy huh
+ CCFLAGS="${CFLAGS}" LINKFLAGS="${LDFLAGS}" "${WAF_BINARY}" \
+ --prefix=/usr \
+ --enable-gl \
+ ${myconf} \
+ configure || die "configure failed"
+}
diff --git a/app-benchmarks/glmark2/glmark2-2011.12.ebuild b/app-benchmarks/glmark2/glmark2-2011.12.ebuild
new file mode 100644
index 0000000..51badd2
--- /dev/null
+++ b/app-benchmarks/glmark2/glmark2-2011.12.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit waf-utils
+
+DESCRIPTION="Opengl test suite"
+HOMEPAGE="https://launchpad.net/glmark2"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gles2"
+
+RDEPEND="media-libs/libpng
+ media-libs/mesa[gles2?]
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/voidp.patch"
+}
+
+src_prepare() {
+ rm -rf ${S}/src/libpng
+ sed -i -e 's#libpng12#libpng#g' ${S}/wscript ${S}/src/wscript_build || die
+}
+
+src_configure() {
+ : ${WAF_BINARY:="${S}/waf"}
+
+ local myconf
+
+ if use gles2; then
+ myconf += "--enable-glesv2"
+ fi
+
+ # it does not know --libdir specification, dandy huh
+ CCFLAGS="${CFLAGS}" LINKFLAGS="${LDFLAGS}" "${WAF_BINARY}" \
+ --prefix=/usr \
+ --enable-gl \
+ ${myconf} \
+ configure || die "configure failed"
+}