summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Nagy <danielnagy@gmx.de>2012-06-14 20:17:25 +0200
committerDaniel Nagy <danielnagy@gmx.de>2012-06-14 20:17:25 +0200
commit48ce48de5308573fd5293eed913055cdecdc37f9 (patch)
treed3d32f84d9896ab1e55970706d2983cf1a7afce7 /dev-python/portalocker/portalocker-0.3.ebuild
parentadding htty 1.4.0 (diff)
downloaddrevilt-48ce48de5308573fd5293eed913055cdecdc37f9.tar.gz
drevilt-48ce48de5308573fd5293eed913055cdecdc37f9.tar.bz2
drevilt-48ce48de5308573fd5293eed913055cdecdc37f9.zip
adding portalocker and anttweakbar
Diffstat (limited to 'dev-python/portalocker/portalocker-0.3.ebuild')
-rw-r--r--dev-python/portalocker/portalocker-0.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/portalocker/portalocker-0.3.ebuild b/dev-python/portalocker/portalocker-0.3.ebuild
new file mode 100644
index 0000000..9259131
--- /dev/null
+++ b/dev-python/portalocker/portalocker-0.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+# inherit distutils
+
+DESCRIPTION="portalocker"
+HOMEPAGE="http://code.activestate.com/recipes/65203/"
+SRC_URI="http://code.activestate.com/recipes/65203-portalocker-cross-platform-posixnt-api-for-flock-s/download/1/ -> ${P}.py"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_install() {
+ mkdir -p ${D}/usr/bin
+ cp ${DISTDIR}/${P}.py ${D}/usr/bin/${PN}
+ chmod +x ${D}/usr/bin/${PN}
+ sed -i"" -e '1 i #!/usr/bin/env python' ${D}/usr/bin/${PN}
+}