summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Nagy <danielnagy@gmx.de>2011-06-14 02:15:25 +0200
committerDaniel Nagy <danielnagy@gmx.de>2011-06-14 02:15:25 +0200
commit7ad55cb64a7f92f0186733cf99702e7a995b5a53 (patch)
tree2a05ce37b436632e494671a41c52b056b3c13c12 /js-libs/flot
parentadding jquery and new category (diff)
downloaddrevilt-7ad55cb64a7f92f0186733cf99702e7a995b5a53.tar.gz
drevilt-7ad55cb64a7f92f0186733cf99702e7a995b5a53.tar.bz2
drevilt-7ad55cb64a7f92f0186733cf99702e7a995b5a53.zip
QA, adding metadata and jquery tools and flot
Diffstat (limited to 'js-libs/flot')
-rw-r--r--js-libs/flot/Manifest3
-rw-r--r--js-libs/flot/flot-0.7.ebuild45
-rw-r--r--js-libs/flot/metadata.xml16
3 files changed, 64 insertions, 0 deletions
diff --git a/js-libs/flot/Manifest b/js-libs/flot/Manifest
new file mode 100644
index 0000000..0f75c05
--- /dev/null
+++ b/js-libs/flot/Manifest
@@ -0,0 +1,3 @@
+DIST flot-0.7.tar.gz 288107 RMD160 39da8fe597583317e2810e196442a51facddcd53 SHA1 68ca8b250d18203ebe67136913e0e1c82bbeecfb SHA256 bc24f661d6de1d38496b93147604174dd82b6c54359824cb1c9c4acd5eb55730
+EBUILD flot-0.7.ebuild 829 RMD160 54753e3d6ae390a5ee5e56ced3b7813e1f8d5a4e SHA1 6a41ace5fba9b7ce958607fb50ecbad20e1f50d7 SHA256 4aa0c52067094733d0bab519a7d8a62813a295d9feef44e11ed7c85da185f6d8
+MISC metadata.xml 742 RMD160 d60d6f23b1f33072a806b4e9c2de73e72cf2e419 SHA1 e0f23e41d4fb035f3744881fc0c9c2ef74676caf SHA256 30eb8ab19d76c08fb9024e20d4ce7c26083224e8ec92c1c502c60143b6afecec
diff --git a/js-libs/flot/flot-0.7.ebuild b/js-libs/flot/flot-0.7.ebuild
new file mode 100644
index 0000000..fb5a146
--- /dev/null
+++ b/js-libs/flot/flot-0.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit webapp versionator eutils
+
+DESCRIPTION="a pure Javascript plotting library for jQuery"
+HOMEPAGE="http://code.google.com/p/${PN}/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples minimal"
+
+DEPEND="js-libs/jquery"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/jquery.flot.js" "${S}/"
+ cp "${DISTDIR}/jquery.flot.*.js" "${S}/"
+ if [ use examples ] ; then
+ cp "${DISTDIR}/examples/*" "${S}/examples/"
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+ webapp_src_install
+ insinto "${MY_HTDOCSDIR}"
+ doins "${P}.js" "${P}.min.js"
+}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+}
diff --git a/js-libs/flot/metadata.xml b/js-libs/flot/metadata.xml
new file mode 100644
index 0000000..5ec1f21
--- /dev/null
+++ b/js-libs/flot/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>danielnagy@gmx.de</email>
+ <name>Daniel Nagy</name>
+</maintainer>
+<longdescription>Flot is a pure Javascript plotting library for jQuery. It
+ produces graphical plots of arbitrary datasets on-the-fly client-side.
+ The focus is on simple usage (all settings are optional), attractive
+ looks and interactive features like zooming and mouse tracking.
+ The plugin works with Internet Explorer 6+, Firefox 2.x+, Safari 3.0+,
+ Opera 9.5+ and Konqueror 4.x+ with the HTML canvas tag (the excanvas
+ Javascript emulation helper is used for IE &lt; 9).</longdescription>
+</pkgmetadata>