summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Nagy <danielnagy@gmx.de>2011-06-13 21:37:27 +0200
committerDaniel Nagy <danielnagy@gmx.de>2011-06-13 21:37:27 +0200
commit6353a2e83d0d7c07d0f491fcec09174030b95931 (patch)
tree424d26d531ee2c6afc0126a017f8641c27ce726f /js-libs/jquery/jquery-1.6.1.ebuild
parentadding curlpp (diff)
downloaddrevilt-6353a2e83d0d7c07d0f491fcec09174030b95931.tar.gz
drevilt-6353a2e83d0d7c07d0f491fcec09174030b95931.tar.bz2
drevilt-6353a2e83d0d7c07d0f491fcec09174030b95931.zip
adding jquery and new category
Diffstat (limited to 'js-libs/jquery/jquery-1.6.1.ebuild')
-rw-r--r--js-libs/jquery/jquery-1.6.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/js-libs/jquery/jquery-1.6.1.ebuild b/js-libs/jquery/jquery-1.6.1.ebuild
new file mode 100644
index 0000000..b54e1ca
--- /dev/null
+++ b/js-libs/jquery/jquery-1.6.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit webapp versionator eutils
+
+DESCRIPTION="a fast and concise JavaScript Library"
+HOMEPAGE="http://jquery.com"
+SRC_URI="http://code.jquery.com/${P}.js http://code.jquery.com/${P}.min.js"
+
+LICENSE="|| ( MIT GPL-2 )"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/${P}.js" "${S}/"
+ cp "${DISTDIR}/${P}.min.js" "${S}/"
+}
+
+src_install() {
+ webapp_src_preinst
+ webapp_src_install
+ insinto "${MY_HTDOCSDIR}"
+ doins "${P}.js" "${P}.min.js"
+}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+}