summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Nagy <danielnagy@gmx.de>2011-10-22 00:49:44 +0200
committerDaniel Nagy <danielnagy@gmx.de>2011-10-22 00:49:44 +0200
commit3a8cae440ab8c89b38b013379e74d31fec03d0c3 (patch)
tree446ab8f5654f6ea6d1b5275ca8823f7b51b7525f /js-libs/jquery/jquery-1.6.4.ebuild
parentadding datejs (diff)
downloaddrevilt-3a8cae440ab8c89b38b013379e74d31fec03d0c3.tar.gz
drevilt-3a8cae440ab8c89b38b013379e74d31fec03d0c3.tar.bz2
drevilt-3a8cae440ab8c89b38b013379e74d31fec03d0c3.zip
jquery version bump
Diffstat (limited to 'js-libs/jquery/jquery-1.6.4.ebuild')
-rw-r--r--js-libs/jquery/jquery-1.6.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/js-libs/jquery/jquery-1.6.4.ebuild b/js-libs/jquery/jquery-1.6.4.ebuild
new file mode 100644
index 0000000..5fd97d9
--- /dev/null
+++ b/js-libs/jquery/jquery-1.6.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+inherit webapp versionator eutils
+
+DESCRIPTION="a fast and concise JavaScript Library"
+HOMEPAGE="http://jquery.com/"
+SRC_URI="http://code.jquery.com/${P}.js http://code.jquery.com/${P}.min.js"
+
+LICENSE="|| ( MIT GPL-2 )"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/${P}.js" "${S}/"
+ cp "${DISTDIR}/${P}.min.js" "${S}/"
+ ln -s "${P}.js" "${PN}.js"
+ ln -s "${P}.min.js" "${PN}.min.js"
+}
+
+src_install() {
+ webapp_src_preinst
+ webapp_src_install
+ insinto "${MY_HTDOCSDIR}"
+ doins "${P}.js" "${P}.min.js" "${PN}.js" "${PN}.min.js"
+}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+}