summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Nagy <danielnagy@gmx.de>2011-10-21 23:46:06 +0200
committerDaniel Nagy <danielnagy@gmx.de>2011-10-21 23:46:06 +0200
commit6d3fd06ba398c0b608da2f08b7d5aa370c0da85e (patch)
tree0047741e65d5923dd04fc4877ac9bde81f9ce667 /net-libs/libwebsockets/libwebsockets-9999.ebuild
parentadding blockui, extjs and jqueryui (diff)
downloaddrevilt-6d3fd06ba398c0b608da2f08b7d5aa370c0da85e.tar.gz
drevilt-6d3fd06ba398c0b608da2f08b7d5aa370c0da85e.tar.bz2
drevilt-6d3fd06ba398c0b608da2f08b7d5aa370c0da85e.zip
adding libwebsockets and htty
Diffstat (limited to 'net-libs/libwebsockets/libwebsockets-9999.ebuild')
-rw-r--r--net-libs/libwebsockets/libwebsockets-9999.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-libs/libwebsockets/libwebsockets-9999.ebuild b/net-libs/libwebsockets/libwebsockets-9999.ebuild
new file mode 100644
index 0000000..76e9204
--- /dev/null
+++ b/net-libs/libwebsockets/libwebsockets-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+EGIT_REPO_URI="git://git.warmcat.com/libwebsockets"
+
+inherit git-2
+
+DESCRIPTION="C Websockets Server Library"
+HOMEPAGE="http://warmcat.com/libwebsockets"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="openssl +libcrypto nofork noping"
+DEPEND="openssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ git_src_unpack
+ cd "${S}"
+}
+
+src_configure() {
+ econf \
+ $(use_enable openssl) \
+ $(use_enable libcrypto) \
+ $(use_enable nofork) \
+ $(use_enable noping)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc README-test-server
+}