summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-java/json-java/Manifest2
-rw-r--r--dev-java/json-java/json-java-9999.ebuild25
-rw-r--r--dev-java/json-java/metadata.xml11
-rw-r--r--dev-java/parallel-ant/parallel-ant-0.9.ebuild46
-rw-r--r--dev-python/hamlpy/Manifest1
-rw-r--r--dev-python/hamlpy/hamlpy-9999.ebuild22
-rw-r--r--dev-python/ws4py/Manifest1
-rw-r--r--dev-python/ws4py/ws4py-9999.ebuild22
-rw-r--r--sys-fs/iwatch/Manifest2
-rw-r--r--sys-fs/iwatch/iwatch-0.2.2.ebuild42
-rw-r--r--www-apps/owncloud/Manifest2
-rw-r--r--www-apps/owncloud/owncloud-2.0.1.ebuild43
12 files changed, 219 insertions, 0 deletions
diff --git a/dev-java/json-java/Manifest b/dev-java/json-java/Manifest
new file mode 100644
index 0000000..a62105e
--- /dev/null
+++ b/dev-java/json-java/Manifest
@@ -0,0 +1,2 @@
+EBUILD json-java-9999.ebuild 456 RMD160 2a9192091285f49edc4713e9e811be3a33dec534 SHA1 7ff9020b2de24028e2a101ae33a6a8d01f85abee SHA256 7aa617724039f59534210e36003c528d0bd967af35b1d6e662d3ab8049e86029
+MISC metadata.xml 337 RMD160 882d549274c590e68ceeb3747a953b5352c6083e SHA1 3c2b9d7de633d40c07f9cb012b3935168d26e561 SHA256 23b8b7beb25e7142375b41b52e2b1445e185cf01cdf9e067d69ac0d4754ffef7
diff --git a/dev-java/json-java/json-java-9999.ebuild b/dev-java/json-java/json-java-9999.ebuild
new file mode 100644
index 0000000..e0b177e
--- /dev/null
+++ b/dev-java/json-java/json-java-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+EGIT_REPO_URI="git://github.com/douglascrockford/JSON-java.git"
+
+inherit git-2
+
+DESCRIPTION="A reference implementation of a JSON package in Java."
+HOMEPAGE="https://github.com/douglascrockford/JSON-java"
+SRC_URI=""
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=""
+DEPEND="test? (
+ dev-lang/junit
+ )"
+
+# incomplete ...
diff --git a/dev-java/json-java/metadata.xml b/dev-java/json-java/metadata.xml
new file mode 100644
index 0000000..49c74e9
--- /dev/null
+++ b/dev-java/json-java/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>danielnagy@gmx.de</email>
+ <name>Daniel Nagy</name>
+</maintainer>
+<longdescription>A reference implementation of a JSON package in Java.</longdescription>
+</pkgmetadata>
+
diff --git a/dev-java/parallel-ant/parallel-ant-0.9.ebuild b/dev-java/parallel-ant/parallel-ant-0.9.ebuild
new file mode 100644
index 0000000..9577e77
--- /dev/null
+++ b/dev-java/parallel-ant/parallel-ant-0.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit java-pkg-2 java-ant-2
+
+EAPI=2
+
+DESCRIPTION="pant"
+HOMEPAGE="http://blog.codeaholics.org/parallel-ant/"
+SRC_URI="https://github.com/codeaholics/parallel-ant/tarball/0.9-beta -> ${P}.tar.gz"
+
+LICENSE="Apache"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+COMMON_DEP="dev-java/ant"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEP}"
+
+#java_prepare() {
+# JAVA_ANT_CLASSPATH_TAGS="javac java" java-ant_rewrite-classpath
+#}
+
+EANT_GENTOO_CLASSPATH="ant-core"
+
+src_configure() {
+ mv codeaholics-${PN}-0a67d42 ${P}
+ cd ${P}
+}
+
+src_compile() {
+ JAVA_ANT_CLASSPATH_TAGS="javac java" java-ant_rewrite-classpath
+ eant || die
+}
+
+src_install() {
+ java-pkg_dojar build/${P}-beta.jar
+ insinto /usr/share/${PN}
+# doins "${FILESDIR}/${PN}-${SLOT}"
+}
diff --git a/dev-python/hamlpy/Manifest b/dev-python/hamlpy/Manifest
new file mode 100644
index 0000000..ba153cc
--- /dev/null
+++ b/dev-python/hamlpy/Manifest
@@ -0,0 +1 @@
+EBUILD hamlpy-9999.ebuild 519 RMD160 640e4ac0029510e374abae3e5d6a8c78cbf53368 SHA1 0109ffd9d966fc94a1207e72cf4afe5d0e1bfa7e SHA256 08cbfe1b63a8ecb30a3c379632fb6bc7676e333f1237e1de604eabbf7f6a2d5a
diff --git a/dev-python/hamlpy/hamlpy-9999.ebuild b/dev-python/hamlpy/hamlpy-9999.ebuild
new file mode 100644
index 0000000..6d07006
--- /dev/null
+++ b/dev-python/hamlpy/hamlpy-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wstools/wstools-0.3.ebuild,v 1.6 2011/09/20 23:38:05 floppym Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+
+EGIT_REPO_URI="git://github.com/jessemiller/HamlPy.git"
+
+inherit distutils git-2
+
+DESCRIPTION="${PN}"
+HOMEPAGE="https://github.com/jessemiller/HamlPy"
+SRC_URI=""
+
+LICENSE="MIT" # ?
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND="dev-python/django"
diff --git a/dev-python/ws4py/Manifest b/dev-python/ws4py/Manifest
new file mode 100644
index 0000000..e523744
--- /dev/null
+++ b/dev-python/ws4py/Manifest
@@ -0,0 +1 @@
+EBUILD ws4py-9999.ebuild 546 RMD160 5b3b73b6fc4cde73f931afa19e7ef5ff6008f00b SHA1 8a742383e2db4dc748d9428e1d28c085174ee8a3 SHA256 cac5cae28d4768218a092fd63c252f01847a38ba6bf942a357d249ee221ae672
diff --git a/dev-python/ws4py/ws4py-9999.ebuild b/dev-python/ws4py/ws4py-9999.ebuild
new file mode 100644
index 0000000..7f3f1f8
--- /dev/null
+++ b/dev-python/ws4py/ws4py-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wstools/wstools-0.3.ebuild,v 1.6 2011/09/20 23:38:05 floppym Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+
+EGIT_REPO_URI="git://github.com/Lawouach/WebSocket-for-Python.git"
+
+inherit distutils git-2
+
+DESCRIPTION="${PN}"
+HOMEPAGE="https://github.com/Lawouach/WebSocket-for-Python"
+SRC_URI=""
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND=">=dev-python/gevent-0.13.6"
diff --git a/sys-fs/iwatch/Manifest b/sys-fs/iwatch/Manifest
new file mode 100644
index 0000000..477677b
--- /dev/null
+++ b/sys-fs/iwatch/Manifest
@@ -0,0 +1,2 @@
+DIST iwatch-0.2.2.tgz 16819 RMD160 a6d8c2ef053ac611699edff2e38d7402a92db5f3 SHA1 a9bce69a56cc9ed772c9d338238613a502671729 SHA256 beb2b8326b90130b3102cba38e6efb1f73622e9b52ea1b1da6270e2365ee0fe7
+EBUILD iwatch-0.2.2.ebuild 850 RMD160 71f4ff7adae39c39ae34d4d15b68356b13a7dc00 SHA1 5ad3aaf3bf04d83027ab9944e15a521e16645b54 SHA256 282ec5e79f319d1cb0eaca454a40d0c7bf59951e082590bb011b4e9875344168
diff --git a/sys-fs/iwatch/iwatch-0.2.2.ebuild b/sys-fs/iwatch/iwatch-0.2.2.ebuild
new file mode 100644
index 0000000..b1fb0d3
--- /dev/null
+++ b/sys-fs/iwatch/iwatch-0.2.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+
+DESCRIPTION="A realtime filesystem monitoring program."
+HOMEPAGE="http://sourceforge.net/projects/iwatch"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+ dev-perl/Linux-Inotify2
+ dev-perl/Event
+ dev-perl/Mail-Sendmail
+ dev-perl/XML-Simple
+ dev-perl/XML-SimpleObject"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i \
+ -e "s|/etc|${ROOT}usr/share/iwatch|" \
+ iwatch.xml{,.example} || die "sed failed"
+}
+
+src_install() {
+ dobin iwatch
+ dodoc AUTHORS ChangeLog README iwatch.xml iwatch.xml.example
+
+ insinto /usr/share/iwatch
+ doins iwatch.dtd
+}
+
+pkg_postinst() {
+ elog "Example configuration files are in ${ROOT}usr/share/doc/${PF}"
+}
diff --git a/www-apps/owncloud/Manifest b/www-apps/owncloud/Manifest
new file mode 100644
index 0000000..b508589
--- /dev/null
+++ b/www-apps/owncloud/Manifest
@@ -0,0 +1,2 @@
+DIST owncloud-2.0.1.tar.bz2 1152652 RMD160 84d1fab96a34b365fc36f4fbba05a8339540a1f5 SHA1 a3223e5861ddf5a260e8d99a4280ddbc768e04cf SHA256 811d2c1f5d80dd9cba426c3e462a77357ded3ea5391088914d01f2eccf69edbb
+EBUILD owncloud-2.0.1.ebuild 942 RMD160 f29124e206c813c626f3132bdb61695fe959a500 SHA1 b442a2b779df8c34dd463f0868f3f720477dcb8a SHA256 e8308f8c4e6097b6d096b86137c63ce9c262c8440d5d4cb8c8e195894c470b23
diff --git a/www-apps/owncloud/owncloud-2.0.1.ebuild b/www-apps/owncloud/owncloud-2.0.1.ebuild
new file mode 100644
index 0000000..5b1feaa
--- /dev/null
+++ b/www-apps/owncloud/owncloud-2.0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/owncloud/owncloud-1.2.ebuild,v 1.1 2011/04/27 12:10:20 alexxy Exp $
+
+inherit webapp eutils depend.php
+
+MY_PV=${PV:0:3}.0
+
+DESCRIPTION="Web-based storage application where all your data is under your own control"
+HOMEPAGE="http://owncloud.org"
+SRC_URI="http://owncloud.org/releases/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}/${P/_/-}"
+
+pkg_setup() {
+ flags="json xmlwriter zip"
+ webapp_pkg_setup
+ has_php
+ require_php_with_use ${flags}
+}
+
+src_install() {
+ cd owncloud
+ webapp_src_preinst
+
+ local docs="README docs/*"
+ dodoc ${docs}
+ rm -f ${docs}
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ dodir "${MY_HTDOCSDIR}"/data
+ webapp_serverowned "${MY_HTDOCSDIR}"/data
+ webapp_serverowned "${MY_HTDOCSDIR}"/config
+
+ webapp_src_install
+}