summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'js-libs/jquerytools/jquerytools-1.2.5.ebuild')
-rw-r--r--js-libs/jquerytools/jquerytools-1.2.5.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/js-libs/jquerytools/jquerytools-1.2.5.ebuild b/js-libs/jquerytools/jquerytools-1.2.5.ebuild
new file mode 100644
index 0000000..5af04a6
--- /dev/null
+++ b/js-libs/jquerytools/jquerytools-1.2.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit webapp versionator eutils
+
+DESCRIPTION="The missing UI library for the Web"
+HOMEPAGE="http://flowplayer.org/tools/"
+SRC_URI="http://cdn.jquerytools.org/${PV}/all/jquery.tools.min.js"
+
+SLOT="0"
+
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples minimal"
+
+DEPEND="js-libs/jquery"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/jquery.flot.js" "${S}/"
+ cp "${DISTDIR}/jquery.flot.*.js" "${S}/"
+ if [ use examples ] ; then
+ cp "${DISTDIR}/examples/*" "${S}/examples/"
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+ webapp_src_install
+ insinto "${MY_HTDOCSDIR}"
+ doins "${P}.js" "${P}.min.js"
+}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+}