summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'js-libs/jqueryui/jqueryui-1.8.14.ebuild')
-rw-r--r--js-libs/jqueryui/jqueryui-1.8.14.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/js-libs/jqueryui/jqueryui-1.8.14.ebuild b/js-libs/jqueryui/jqueryui-1.8.14.ebuild
new file mode 100644
index 0000000..c661657
--- /dev/null
+++ b/js-libs/jqueryui/jqueryui-1.8.14.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+inherit webapp versionator eutils
+
+MY_P="jquery-ui-${PV}"
+
+DESCRIPTION="an UI library for jquery"
+HOMEPAGE="http://jqueryui.com/"
+SRC_URI="http://jqueryui.com/download/${MY_P}.custom.zip"
+
+LICENSE="|| ( MIT GPL-2 )"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack "${MY_P}.custom.zip"
+ ln -s "${MY_P}.custom.min.js" "js/${PN}.min.js"
+ ln -s "${MY_P}.custom.css" "css/smoothness/${PN}.css"
+}
+
+src_install() {
+ webapp_src_preinst
+ webapp_src_install
+ insinto "${MY_HTDOCSDIR}"
+ doins "js/${MY_P}.custom.min.js" "js/${PN}.min.js"
+ doins "css/smoothness/${MY_P}.custom.css" "css/smoothness/${PN}.css"
+}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+}