summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/anttweakbar/anttweakbar-1.14.ebuild')
-rw-r--r--media-libs/anttweakbar/anttweakbar-1.14.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/anttweakbar/anttweakbar-1.14.ebuild b/media-libs/anttweakbar/anttweakbar-1.14.ebuild
new file mode 100644
index 0000000..c2b1597
--- /dev/null
+++ b/media-libs/anttweakbar/anttweakbar-1.14.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+DESCRIPTION="A library that adds an easy GUI into OpenGL applications to interactively tweak them on-screen"
+HOMEPAGE="http://www.antisphere.com/Wiki/tools:anttweakbar?sb=tools"
+
+SRC_URI="http://www.antisphere.com/Tools/AntTweakBar/AntTweakBar?v -> ${P}.zip"
+
+KEYWORDS="~x86 ~amd64"
+LICENSE="ZLIB"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="$DEPEND"
+
+S="${WORKDIR}/AntTweakBar"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd src
+ emake || die "${P} could not be compiled"
+}
+
+src_install() {
+ dolib lib/libAntTweakBar.so
+ dolib lib/libAntTweakBar.so.1
+ insinto /usr/include
+ doins include/AntTweakBar.h
+}