summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCosmonauT <cosmonaut@a.ua>2012-05-27 19:07:26 +0300
committerCosmonauT <cosmonaut@a.ua>2012-05-27 19:07:26 +0300
commitf302f94d55a8c70cc6bc25f74532aacdda213a35 (patch)
tree6177c092c5cc56248ceb210720a855f950402ef9
parentInitial (diff)
downloaddswm-f302f94d55a8c70cc6bc25f74532aacdda213a35.tar.gz
dswm-f302f94d55a8c70cc6bc25f74532aacdda213a35.tar.bz2
dswm-f302f94d55a8c70cc6bc25f74532aacdda213a35.zip
added ebuild for dswm v.0.0.4
-rw-r--r--profiles/repo_name2
-rw-r--r--x11-wm/dswm/Manifest2
-rw-r--r--x11-wm/dswm/dswm-0.0.4.ebuild59
3 files changed, 62 insertions, 1 deletions
diff --git a/profiles/repo_name b/profiles/repo_name
index d4fa550..560452a 100644
--- a/profiles/repo_name
+++ b/profiles/repo_name
@@ -1 +1 @@
-dswm
+dswm \ No newline at end of file
diff --git a/x11-wm/dswm/Manifest b/x11-wm/dswm/Manifest
index 192d777..0360d8a 100644
--- a/x11-wm/dswm/Manifest
+++ b/x11-wm/dswm/Manifest
@@ -1,3 +1,5 @@
AUX README.Gentoo 238 RMD160 fa6572bb56d61fb3b0f5a5b94c23c3435ee36d59 SHA1 1c135edac026bf7784e083b9f6a837a17706375a SHA256 14163e2306da972d198c6fdba60ab087497249a05b0bc27567cbf15588c67a15
DIST dswm-0.0.3-git.tar.gz 258723 RMD160 9ce59ddec0481861849c11c83aa116875ba1775a SHA1 aaed90c25d8c95070b2d3355291c4d2b22365ba6 SHA256 4ccc063ac10fbd4f5b30c24988c2b35665677b3cdde9f483fbbf2bbe53905f78
+DIST dswm-0.0.4.tar.gz 310377 RMD160 56fb14fc603e8394de4260709df5308b3e2abba0 SHA1 d1e5d1e46159ae988184060971542671ababa3ba SHA256 f5adc2f4fcd6d2f458a99f651da42544ab4cee4ce29852c7891c505e0bbaccb7
EBUILD dswm-0.0.3.ebuild 1478 RMD160 9f45e267d6b0941396ac2bcb9a58fe6efa3353df SHA1 9c8e89faa4e1255294704e52ffa502d1a0254561 SHA256 9e9a9ff72e102e811db312202ff56679bd65013de536a9f87ae63595edeebac3
+EBUILD dswm-0.0.4.ebuild 1373 RMD160 463f2511e83e0511c179c04faaa51d51fc947e2c SHA1 f1ca32239f6b9bc0c50bead96e72fb3cd6ad2af4 SHA256 f2a0bacf181ddabbe8b784d4c0c1eb3e277c53ea7c79d53e4d6bb00e3c91eea1
diff --git a/x11-wm/dswm/dswm-0.0.4.ebuild b/x11-wm/dswm/dswm-0.0.4.ebuild
new file mode 100644
index 0000000..f6f8f52
--- /dev/null
+++ b/x11-wm/dswm/dswm-0.0.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dswm/dswm-0.0.3.ebuild,v 1.2 2011/04/25 20:36:20 betelgeuse Exp $
+
+EAPI="2"
+
+inherit common-lisp autotools eutils
+
+DESCRIPTION="DSWM is a tiling, keyboard driven X11 Window Manager written entirely in Common Lisp."
+# HOMEPAGE="http://dss-project.org"
+SRC_URI="http://sourceforge.net/projects/dswm/files/0.0.4/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="emacs doc"
+
+CLPACKAGE="dswm"
+
+DEPEND="dev-lisp/common-lisp-controller
+ >=dev-lisp/sbcl-1.0.36-r1
+ dev-lisp/clx
+ dev-lisp/cl-ppcre
+ doc? ( sys-apps/texinfo )"
+
+RDEPEND="x11-base/xorg-server
+ emacs? ( app-emacs/slime )"
+
+src_prepare() {
+ mv ${P}-git/* .
+ rm -rf ${P}-git/
+ eautoconf
+}
+
+src_configure() {
+ ## sed "s,@PACKAGE_VERSION@,$PV,g" version.lisp.in > version.lisp
+ ## autocnof
+ ##./configure --prefix=/usr --with-lisp=sbcl || die
+ # autoconf
+ econf \
+ --prefix=/usr --with-lisp=sbcl ${myconf}
+}
+
+src_compile() {
+ emake
+ use doc && makeinfo dswm.texi
+}
+
+src_install() {
+ common-lisp-install *.lisp dswm.asd
+ common-lisp-system-symlink
+ emake destdir=${D} install
+ dodoc README NEWS ChangeLog "${FILESDIR}/README.Gentoo" || die
+ use doc && doinfo dswm.info
+}
+
+pkg_postinst() {
+ common-lisp_pkg_postinst
+ cat "${FILESDIR}/README.Gentoo"
+}