summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vynnyk <cosmonaut.ok@gmail.com>2011-04-26 15:13:16 +0300
committerAlexander Vynnyk <cosmonaut.ok@gmail.com>2011-04-26 15:13:16 +0300
commite82d66dd0a00d6db998fb22cfe4889fffe510b7d (patch)
tree8d04d1ff73b139f6f3593e36e8430dc8258aeff4 /x11-wm/dswm/dswm-0.0.3.ebuild
parentInitoal (diff)
downloaddswm-e82d66dd0a00d6db998fb22cfe4889fffe510b7d.tar.gz
dswm-e82d66dd0a00d6db998fb22cfe4889fffe510b7d.tar.bz2
dswm-e82d66dd0a00d6db998fb22cfe4889fffe510b7d.zip
Initial
Diffstat (limited to 'x11-wm/dswm/dswm-0.0.3.ebuild')
-rw-r--r--x11-wm/dswm/dswm-0.0.3.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/x11-wm/dswm/dswm-0.0.3.ebuild b/x11-wm/dswm/dswm-0.0.3.ebuild
new file mode 100644
index 0000000..af8ec4a
--- /dev/null
+++ b/x11-wm/dswm/dswm-0.0.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dswm/dswm-0.0.3.ebuild,v 1.2 2011/04/25 20:36:20 betelgeuse Exp $
+
+EAPI="2"
+
+inherit common-lisp autotools eutils
+
+DESCRIPTION="Stumpwm is a tiling, keyboard driven X11 Window Manager written entirely in Common Lisp."
+# HOMEPAGE="http://www.nongnu.org/stumpwm/index.html"
+# SRC_URI="http://download.savannah.nongnu.org/releases/stumpwm/${P}.tgz"
+SRC_URI="http://sourceforge.net/projects/dswm/files/0.0.3-git/${P}-git.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="emacs doc"
+
+CLPACKAGE="dswm"
+
+DEPEND="dev-lisp/common-lisp-controller
+ =dev-lisp/sbcl-1.0.36-r1
+ dev-lisp/cl-clx
+ dev-lisp/cl-ppcre
+ doc? ( sys-apps/texinfo )"
+
+RDEPEND="x11-base/xorg-server
+ emacs? ( app-emacs/slime )"
+
+src_prepare() {
+ mv ${P}-git/* .
+ rm -rf ${P}-git/
+ eautoconf
+}
+
+src_configure() {
+ ## sed "s,@PACKAGE_VERSION@,$PV,g" version.lisp.in > version.lisp
+ ## autocnof
+ ##./configure --prefix=/usr --with-lisp=sbcl || die
+ # autoconf
+ econf \
+ --prefix=/usr --with-lisp=sbcl ${myconf}
+}
+
+src_compile() {
+ emake
+ use doc && makeinfo dswm.texi
+}
+
+src_install() {
+ common-lisp-install *.lisp dswm.asd
+ common-lisp-system-symlink
+ emake destdir=${D} install
+ dodoc README NEWS ChangeLog "${FILESDIR}/README.Gentoo" || die
+ use doc && doinfo dswm.info
+}
+
+pkg_postinst() {
+ common-lisp_pkg_postinst
+ cat "${FILESDIR}/README.Gentoo"
+}