summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRegna <ki@baka.bakka.su>2013-11-13 14:23:55 +0400
committerRegna <ki@baka.bakka.su>2013-11-13 14:23:55 +0400
commit6d988a8a4c7182b7ca94c97ca4d5db25a86173e6 (patch)
tree50db5a1d9f74ae726560b0a4163e21d3c1fcbe1f /x11-wm/dswm/dswm-9999.ebuild
parentdev-lisp/clx from lisp overlay added (diff)
downloaddswm-6d988a8a4c7182b7ca94c97ca4d5db25a86173e6.tar.gz
dswm-6d988a8a4c7182b7ca94c97ca4d5db25a86173e6.tar.bz2
dswm-6d988a8a4c7182b7ca94c97ca4d5db25a86173e6.zip
dswm-0.1.ebuild dswm-9999.ebuild were added.
Diffstat (limited to 'x11-wm/dswm/dswm-9999.ebuild')
-rw-r--r--x11-wm/dswm/dswm-9999.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/x11-wm/dswm/dswm-9999.ebuild b/x11-wm/dswm/dswm-9999.ebuild
new file mode 100644
index 0000000..11599c0
--- /dev/null
+++ b/x11-wm/dswm/dswm-9999.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dswm/dswm-0.0.3.ebuild,v 1.2 2011/04/25 20:36:20 betelgeuse Exp $
+
+EAPI="5"
+
+inherit common-lisp autotools eutils git-2
+
+DESCRIPTION="DSWM is a tiling, keyboard driven X11 Window Manager written entirely in Common Lisp"
+HOMEPAGE="http://dss-project.org"
+EGIT_REPO_URI="git://github.com/dss-project/dswm.git"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="+lisp-overlay +sbcl +static shared clisp cmucl ecl emacs doc"
+
+CLPACKAGE="dswm"
+
+CDEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp
+ dev-lisp/cl-ppcre
+ lisp-overlay? ( sbcl? ( >=dev-lisp/sbcl-1.0.58
+ >=dev-lisp/clx-0.7.4 )
+ >=dev-lisp/asdf-2.0 )
+ !lisp-overlay? ( sbcl? ( dev-lisp/sbcl
+ dev-lisp/cl-clx )
+ dev-lisp/asdf )
+ clisp? ( dev-lisp/clisp )
+ cmucl? ( dev-lisp/cmucl )
+ ecl? ( dev-lisp/ecls )
+ !dev-lisp/asdf-binary-locations"
+DEPEND="${CDEPEND}
+ doc? ( sys-apps/texinfo )"
+RDEPEND="x11-base/xorg-server
+ emacs? ( app-emacs/slime )
+ shared? ( ${CDEPEND} )"
+REQUIRED_USE="^^ ( sbcl clisp cmucl ecl )
+ || ( shared static )"
+
+S="${WORKDIR}/${P}-git"
+src_prepare() {
+ cd "${S}"/src
+ eautoconf
+ cd "${S}"
+}
+src_configure() {
+ local with_lisp
+ cd "${S}"/src
+ for flag in "sbcl" "clisp" "cmucl" "ecl"; do
+ use $flag && with_lisp="${flag}" && break
+ done
+ if [ "${with_lisp}" != "sbcl" ]; then
+ ewarn "${with_lisp} support in ebuild is untested."
+ ewarn "Write me if you got it to work."
+ fi
+ econf --with-lisp="${with_lisp}" \
+ --with-dswm-source-dir="${D}/usr/share/common-lisp/source/${PN}" \
+ $(use_enable static) $(use_enable shared)
+ cd "${S}"
+}
+src_compile() {
+ cd "${S}"/src
+ emake || die "Make failed"
+ cd "${S}"
+}
+src_install() {
+ cd "${S}/src"
+ common-lisp-install *.lisp dswm.asd
+ common-lisp-system-symlink
+ emake DESTDIR="${D}" install || die "Install failed"
+ cd "${S}"
+ dodoc README NEWS || die
+ use doc && doinfo doc/dswm.info
+}
+pkg_postinst() {
+ common-lisp_pkg_postinst
+ if use shared; then
+ elog "When both shared and static modes enabled, 'make install' creates 2 files:"
+ elog "/usr/bin/dswm - script, for loading DSWM"
+ elog "(you can use it with $LISP env variable: LISP=clisp dswm)"
+ elog "and /usr/bin/dswm.static - static binary,"
+ elog "else 'make install' creates only ${prefix}/bin/dswm"
+ fi
+}