summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/freeorion/freeorion-scm.ebuild')
-rw-r--r--games-strategy/freeorion/freeorion-scm.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-strategy/freeorion/freeorion-scm.ebuild b/games-strategy/freeorion/freeorion-scm.ebuild
new file mode 100644
index 0000000..d03e332
--- /dev/null
+++ b/games-strategy/freeorion/freeorion-scm.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+ESVN_REPO_URI="https://freeorion.svn.sourceforge.net/svnroot/freeorion/trunk/"
+
+inherit games cmake-utils subversion
+
+DESCRIPTION="FreeOrion brings nation building to a galactic scale with its full-featured grand campaign and in-game racial histories, in addition to the classic 4X model of galactic conquest and tactical combat."
+HOMEPAGE="http://www.freeorion.org/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-libs/boost-1.36
+ <media-gfx/graphviz-2.22[cgraph]
+ sys-libs/zlib
+ || ( media-libs/gigi[ogre] media-libs/gigi[sdl] )
+ media-libs/freealut
+ media-libs/libogg
+ media-libs/openal
+ dev-lang/python
+ media-libs/libvorbis
+ sci-physics/bullet
+ sys-libs/glibc"
+RDEPEND="${DEPEND}"
+
+get_boost_ver() {
+ local link="$(readlink /usr/include/boost)"
+ echo "${link%%/*}"
+}
+
+src_compile() {
+ local mycmakeargs=(
+ "-DBOOST_INCLUDEDIR=/usr/include/$(get_boost_ver)"
+ "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ prepgamesdirs
+}